Opened 4 years ago

Closed 4 years ago

#178 closed defect (fixed)

YUM Update libvncserver fails

Reported by: David McKenna Owned by: ydario
Priority: major Milestone:
Component: rpm Version:
Severity: low Keywords:
Cc:

Description

Tried to do the listed command from both ANPM and the command line and get:

Transaction Summary
================================================================================

Upgrade 1 Package

Total size: 256 k
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.

Killed by SIGSEGV
pid=0x0079 ppid=0x0078 tid=0x0001 slot=0x00c7 pri=0x0200 mc=0x0001 ps=0x0010
C:\USR\BIN\PYTHON2.7.EXE
LIBC066 0:0000f62c
cs:eip=005b:1e76f62c ss:esp=0053:0012f108 ebp=0012f138

ds=0053 es=0053 fs=150b gs=0000 efl=00210246

eax=00000000 ebx=200341dc ecx=ffffffff edx=2003013c edi=00000000 esi=200341d0
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

No problem with other packages (tried gsoap immediately after - both install and uninstall worked fine)

Change History (5)

comment:1 Changed 4 years ago by David McKenna

Also get the same error if I try to YUM REMOVE libvncserver. ANPM says 'Package cannot be uninstalled or no package selected'.

comment:2 Changed 4 years ago by David McKenna

I downgraded rpm from version 4.13 to version 4.8 and now I can install libvncserver. Maybe this problem is related to issue #172.

comment:3 Changed 4 years ago by ydario

  • Owner set to ydario
  • Status changed from new to accepted

The following spec sequence

%pre
%post
%preun
%postun

is calling rpmExtScript() in rpmscript.c with NULL for script parameter. This is probably an upstream bug, I doubt original code can handle this situation too.

comment:4 Changed 4 years ago by ydario

rpm: do not try to start NULL scripts. fixes ticket#178.
Committed revision r693.

comment:5 Changed 4 years ago by ydario

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.