Opened 4 years ago

Closed 4 years ago

#142 closed defect (fixed)

Openssl version 1.0.0r is in error

Reported by: Anchieri Owned by:
Priority: major Milestone:
Component: rpm Version:
Severity: highest Keywords:
Cc:

Description

I have installed the last Openssl version:openssl-1.0.0r-1.oc00.i686.rpm.
that contain this program:
ssl10.dll 1381646 4-03-15 10:21p
and after that I was unable to use CLIPGRAB, SMTUBE and also yum.
All of this program ended without do what it have to do.
I have copied from a previous backup of unixroot, the program:
ssl10.dll 1336584 9-02-14 1:09a
and all return normal.
Please review this program.

Change History (5)

comment:1 Changed 4 years ago by dmik

I have openssl-1.0.0r installed and yum surely works for me. Can you give links to other programs so that I could test?

Also, ssl10.dll from openssl-1.0.0r is libc066-based while the previous version is based on libc065. Are you sure you don't have an original version of libc065.dll hanging around in some of your LIBPATH dirs? That can create weird conflicts since only one version of libc (the real DLL) is allowed to be loaded into the memory at a time (+ plus forwarders to the old DLLs). You may distinguish if it's a forwarder or a real DLL by it's size: the forwarder DLLs are small (a hundred KB) while the real DLL is several megabytes. Please check that.

comment:2 Changed 4 years ago by Anchieri

The unique libc066.dll is this: libc066.dll 1361666 10-26-14 8:16p installed in yum directory (N:\USR\LIB).
The libc065 also installed in this directory is: libc065.dll 157213 10-26-14 8:17p
I have installed also this dll: gcc1.dll 29389 2-02-15 9:25a
To control if I have duplicate .dll in my libpath I use System Setup -> eComstation Kernel object and than I use the duplicate option in libpath to view if exist a duplicate phase.
I can't give you other program that don't function because I have reinstalled the old version of ssl10.dll for use that program, I can redo this phase and repeat the test if you request me.

comment:3 Changed 4 years ago by dmik

Yes, please do. Because I can't reproduce anything so far. Btw, in order to downgrade a package (install the previous version of it), you may simply do yum downgrade openssl (or do something like yum downgrade openssl-1.0.0n to downgrade to a specific version). However, there is some technical problem with repositories ATM so that there is no previous version of openssl there (it should be there, I will fix that soon) but just to let you know.

comment:4 Changed 4 years ago by Anchieri

I don't know what it's happen when I update openssl the first time, but downgrading it and then update it, all thing function now.
Thank you for your tip.
G.M. Anchieri
PS: this ticket can be closed now.

comment:5 Changed 4 years ago by diver

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the test and the message, that all works now.

Note: See TracTickets for help on using tickets.