Custom Query (326 matches)


Show under each result:

Results (19 - 21 of 326)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
Ticket Resolution Summary Owner Reporter
#315 no change needed rpm-yum-bootstrap not working on OS/2 4.52 rlange

I have an ancient Pentium2 running OS/2 Warp CP2 4.52. It's running quite nicely and I'd like to get a few of the rpm packages (mostly cups) on it. I got cups working the manual (non-rpm) way but it was pretty kludgy, so I did a clean install and would like to do it the right way, if possible. Is this machine still a supported configuration? If not, then it should be clearly stated it's not. If so, then there's a technical or documentation problem.

Clean Warp 4.52 install. Added unzip and warpin 1.0.22. Tried:

warpin rpm-yum-bootstrap-1_5-i386.wpi

but WarpIN warned me that libc was required. I found and downloaded:

unpacked it to a temporary directory, and moved usr to \. I added the following to c:\config.sys and rebooted.

SET UNIXROOT=C: Appended C:\usr\lib to LIBPATH Appended C:\usr\bin to PATH SET TMP=C:\tmp SET TMPDIR=C:\tmp

Then I redid:

warpin rpm-yum-bootstrap-1_5-i386.wpi

and it succeeded in installing the bootstrap environment. I launched the yum bootstrap console, and it successfully downloaded the repolist packages and told me to run:

yum install yum

I did that and it spat out a tonne of errors like:

Error: Package: urpo-20150513-11.oc00.i386 (netlabs-rel)

Requires: libc >= 0.6.6

Error: Package: rpm-4.8.1-25.oc00.i386 (netlabs-rel)

Requires: libc066.dll

Error: Package: 2:mmap-0.5-1.oc00.i386 (netlabs-rel)

Requires: libc065.dll

I've cut out a tonne of similar errors, all involving libc. It seems every package that requires libc (pretty much all of them) failed.

I checked the repos manually, and there doesn't seem to be a libc rpm package for i386. Is what I did (use the zip version of libc) correct? (By the way, there are no other libcXXX.dll libraries on the system aside from the one installed by the yum bootstrap package and the one I installed manually in \usr from your zip.)

I also tried moving the LIBPATH for C:\usr\lib to the front of LIBPATH, rebooting, and trying again, but that made no difference.

I see that the bootstrap console uses:


I've checked both of those locations and the libcXXX.dll's are there in both locations. I'm not why yum/rpm isn't finding them...

#316 no change needed ANPM cannot fetch odin-win32k Peter Moylan pmoylan

Error message while trying to install odin-win32k using ANPM:

[u'ERROR with transaction check vs depsolve:', 'libodin = 0.7.1-3 is needed by odin-win32k-0.7.1-3.i386', u'Please report this error at']

#317 no change needed 'Get specific release' troubles.. David McKenna

Just installed ArcaOS 5.0.3 on my laptop (HP Probook 6570b) using 'full control' and installed everything checked, plus SeaMonkey? (and no other option). It works great (with a couple quirks). I noticed that it installed all of the BWW stuff using the i686 version (if there was a choice for that in the install, I missed it). The latest ANPM allows 'Get specific release' and so I went thru and installed as many of the 'Pentium4' versions as I could (after changing the 'platform' variable in ANPM). But there were a few that offered a pentium4 version that didn't work. They just installed the same i686 version (or in one case, the i386 version). They are:

coreutils 8.26-2 fontconfig 2.12-4 mmap 0.5-1 (installed the i386 version) nspr 4.12.0-4 rpm 4.13.0-17 plus rpm-libs 4.13.0-17 yum 3.4.3-11 zlib 1.2.11-2

I was able to choose the previous pentium4 version and downgrade to that, then update to the latest on all but coreutils and rpm and rpm-libs.

Not sure if this is the right place to report this. Please correct me if I should report to ArcaNoae?.


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
Note: See TracQuery for help on using queries.