Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#95 closed task (not a bug)

Problem using QPDFVIEW with a PDF file

Reported by: Anchieri Owned by: diver
Priority: minor Component: qtapps
Version: Keywords:
Cc:

Description

I want print the PDF file: 2014-QUI-F24-TARI-SD.pdf that I attach to this ticket for your convenience to test it. I also attach two image of this file as viewed with QPDFVIEW (QPDFVIEW-01.jpg)and with LUCIDE (LUCIDE-01.jpg) all two program view in the same manner the data. But Lucide print this file with form+data (image LUCIDE-02.jpg) while Qpdfview print only form without data in it (image QPDFVIEW-02.jpg). I can print all my PDF file using one or the other program indifferently but this file has a difference, where is the culprit?. DO you can resolve it?

Attachments (5)

2014-QUI-F24-TARI-SD.pdf (128.6 KB) - added by Anchieri 5 years ago.
LUCIDE-01.jpg (97.6 KB) - added by Anchieri 5 years ago.
LUCIDE-02.jpg (232.3 KB) - added by Anchieri 5 years ago.
QPDFVIEW-01.jpg (135.6 KB) - added by Anchieri 5 years ago.
QPDFVIEW-02.jpg (235.8 KB) - added by Anchieri 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by Anchieri

Changed 5 years ago by Anchieri

Changed 5 years ago by Anchieri

Changed 5 years ago by Anchieri

Changed 5 years ago by Anchieri

comment:1 Changed 5 years ago by diver

  • Owner set to diver
  • Priority changed from major to minor
  • Status changed from new to accepted
  • Type changed from defect to task

This is not a Qpdfview problem. see https://bugs.launchpad.net/ubuntu/+source/qpdf/+bug/923955

I need to check with Paul Smedley if later cups has this pdftopdf cups filter

comment:2 Changed 5 years ago by Anchieri

Please, this file is printed using cups 1.4.8 and HPLIP because my printer is an HP PSC 1610 All in One, Lucide print all data while Qpdfview only the form.

comment:3 Changed 5 years ago by diver

Even if Lucide prints, it's not a Qpdfview error. It's a cups problem as stated above. I will see how a later cups behaves.

comment:4 Changed 5 years ago by psmedley

i think pdftopdf is a part of cups-filters which is needed by cups 1.7 and above...

comment:5 Changed 5 years ago by psmedley

Test document prints fine with CUPS 2.0

comment:6 Changed 5 years ago by diver

  • Resolution set to not a bug
  • Status changed from accepted to closed

@Paul thx for testing. @Anchieri this proves what I told above. It's not a qpdfview problem.

comment:7 Changed 5 years ago by Anchieri

It's very likely that you are wright, but I can't use CUPS 2.0 because after more testing my usb printer don't print anything. It's a hplip printer and I receive always a filter error, beside this it's very difficult to test because of erroneous link that give always the "server internal error" at every send page. If Paul Smedley can resolve this and send to me a new version of cups 2.0 without this error, I can test It more accurately. Thank you for your great work. G.M. Anchieri

Note: See TracTickets for help on using tickets.