Opened 5 years ago

Closed 5 years ago

#94 closed defect (not a bug)

qpdf 0.4.13

Reported by: vrwp Owned by:
Priority: Feedback Pending Component: qtapps
Version: Keywords:
Cc:

Description

cannot open a pdf document. starting qpdf with a log setting, I get following error in the log:

"The file 'E:/PROGRAMS/qpdf/qpdfpdf.dll' is not a valid Qt plugin." Could not load plug-in in second attempt: "" "The shared library was not found." QSqlDatabasePrivate::removeDatabase: connection 'qt_sql_default_connection' is still in use, all queries will cease to work.

I installed all prerequisits with yum. The problem started after updating qpdf and the update of all the packages with yum. Reverting to qpdf 0.4.12 doesn't cure the problem. So I think something happend with the yum update statement.

Change History (6)

comment:1 Changed 5 years ago by vrwp

deleted everything from qpdf en reinstalled everything qpdf version 0.4.13 gives i popuplog.os2 01-10-2015 18:52:24 SYS2070 PID 006d TID 0001 Slot 00ad R:\STUDENT\QPDFVIEW.EXE POPPLE48->TIFF._TIFFFdOpen 127 (although poppler is installed with yum) searched for popp*.* on all drives an nothing found, execpt in usr subdirectory which is used for yum

version 0.4.9 works

comment:2 Changed 5 years ago by Tellie

Hi

Did you did install tiff ?

Yum install libtiff

As from readme

Jpeg, Tiff, Png


  1. yum install libjpeg libtiff libpng
Last edited 5 years ago by Tellie (previous) (diff)

comment:3 Changed 5 years ago by vrwp

Hi,

Tried again:

[C:\] Yum install libtiff Setting up Install Process Package libtiff-3.9.5-1.oc00.i386 already installed and latest version Nothing to do

[C:\]yum install libjpeg libtiff libpng Setting up Install Process Package libjpeg-8c-1.oc00.i386 already installed and latest version Package libtiff-3.9.5-1.oc00.i386 already installed and latest version Package libpng-1.6.10-1.oc00.i386 already installed and latest version Nothing to do

[C:\]

comment:4 Changed 5 years ago by diver

  • Priority changed from major to Feedback Pending

do you have different tiff.dll in your path, on your hd? which tiff.dll is first in your path? did you install qpdfview 0.4.13 in the same dir as you had 0.4.9?

comment:5 Changed 5 years ago by vrwp

installed qpdfview in new directory, but tiff.dll did the trick. from the epdf package (that I use to create pdf documents there is a file tiff.dll dated 22/01/1999 file size 204kb. After I renamed the file qdpf works, funny thing is that e:\usr stated before the edf directory.

Thanks for the good support!!

comment:6 Changed 5 years ago by diver

  • Resolution set to not a bug
  • Status changed from new to closed

The thing is more when gets epdf loaded. If epdf is loaded when you execute qpdfview, Then tiff.dll is already loaded. And qpdfview tried to use that.

But anyway good it's solved. And we try hard to support ppl as good as possible :)

Note: See TracTickets for help on using tickets.