Opened 7 years ago

Closed 7 years ago

#37 closed defect (fixed)

EasyPaint problems editing PBM file

Reported by: ataylor Owned by:
Priority: major Component: qtapps
Version: Keywords:
Cc:

Description

I opened a monochrome PBM file in EasyPaint? 0.1.0 to clean up some background noise with the eraser tool.

After erasing several times, suddenly the entire image disappeared!

Hitting Undo caused it to reappear. From that point on, any edit operation caused the entire image to disappear.

The console showed the following, repeated many times:

QPainter::begin: Paint device returned engine == 0, type: 3 QPainter::setPen: Painter not active QPainter::drawPoints: Painter not active QPainter::end: Painter not active, aborted

I then tried to save the image at that point. EasyPaint? crashed with:

Killed by SIGSEGV pid=0x00b8 ppid=0x00b7 tid=0x0001 slot=0x00bc pri=0x0200 mc=0x0001 E:\PROGRAMS\EASYPAINT\EASYPAINT.EXE QTGUI4 0:000e0e22 cs:eip=005b:1c3d0e22 ss:esp=0053:0015ef18 ebp=0015ef3c

ds=0053 es=0053 fs=150b gs=0000 efl=00210216

eax=00801f80 ebx=00000000 ecx=1bc00002 edx=0015ef6c edi=00801f80 esi=0015efd0 Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

And my image was overwritten by a 0-byte file. :(

(Fortunately I can regenerate it easily from the data source.)

QT 4.7.3

Change History (3)

comment:1 Changed 7 years ago by diver

are you 100% sure it only happens on the Qt4 for ecs (OS/2)?

comment:2 Changed 7 years ago by tellie

Hi Alex,

I compiled a newer build, to the latest git.

Dunno if it fix the problem. I made a ticket for you're problem on the easypaint github.

Please grab it from ftp://ftp.netlabs.org/pub/qtapps/temp/easypaint_0.1.0a_os2.zip

comment:3 Changed 7 years ago by Tellie

  • Resolution set to fixed
  • Status changed from new to closed

Closing this as the new version works now.

Note: See TracTickets for help on using tickets.