Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3 closed defect (wontfix)

Sys1804 on startup (missing file REGISTRY)

Reported by: guest Owned by: dmik
Priority: minor Component: psi
Version: Keywords: registry warp 3
Cc:

Description (last modified by dmik)

Testing psios2-0.10.1-os2/psios2-0_10_1-os2.zip I get a SYS1804 (missing file REGISTRY).

  • Platform: OS/2 Warp 3 Connect FP 40.
  • Version numbers of TCP/IP protocol drivers:
    • SOCKETS.SYS: 6.2004
    • AFOS2.SYS: 6.2000
    • AFINET.SYS: 6.2013
  • Installation directory: D:\installed\psios2
  • Bootdrive: C:
  • USER_INI=c:\OS2\BOS2USER.INI
  • SYSTEM_INI=c:\OS2\BOS2SYS.INI
  • PROTSHELL=c:\OS2\PMSHELL.EXE

C:\registry.dat exists, I've no clue what it is. Applications like Netscape 2.02, 4.61, and Lynx work.

Change History (5)

comment:1 Changed 12 years ago by dmik

Frankly saying, Warp 3 is not supported by Qt for OS/2. The reason for your error is that you don't have the Open32 (Win32-like) Registry component and Psi complains that it cannnot find the REGISTRY.DLL file. You can try to take this file (together with regedit2.exe) from a Warp 4 Fixpak 6 system, however I cannot guarantee that it will work. I don't know how to properly install this component on Warp 3. But in fact, c:\registry.dat has nothing in common with the Open32 Registry.

If you have some success getting the Open32 Registry component (and Psi) work on Warp 3, please report here.

Btw, do you have any significant reason to use Warp 3 nowadays?

comment:2 Changed 12 years ago by dmik

  • Keywords registry warp 3 added
  • Priority changed from major to minor

comment:3 Changed 12 years ago by guest

Thanks for that tip, but a warning for others: Warp 4 FixPak? 6 is on Hobbes, about 20 MB, with 15 Floppy images. Much fun to download it with a V.90 modem, and it's definitely good to have a working floppy driver + something like DSK4PM.

Some hours later I was ready to unpack (or maybe unpack2, that's transparent with my "commander" clone) regconv.ex_ + regedit2.ex_ + regedit.hl_ + registry.dl_ + registry.ms_ (distributed freely to the usual places). Then I tested regconv + regedit2 + psi in that order, and psi started.

I didn't test anything else but this so far. A "jabber for OS/2" was about the only thing I missed with my good old Warp 3 connect. (Don't worry, I've a license for Warp server, but just never the time to fight with its about 7 CD ROMs, and also not the disk space).

Maybe add psi/2 to the list on jabber.org, there might be more OS/2 fans who had this on their wish list. The output of the QT tracker goes to a list available on GMaNe, this (psi) tracker is not available GMaNe. Can I help out with this, e.g. send a subscription request to GMaNe ?

comment:4 Changed 12 years ago by dmik

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from new to closed

Great, your message proves that Warp 3 can be marked as supported by Qt/2 :)

I've contacted the jabber.org person responsible for updating the list (waiting for his reply). Psi is already there of course, but mentioning OS/2 as the supported platform will be really nice.

About GMaNe. Both me and Adrian (the netlabs.org maintainer) have requested GMaNe to subscribe to qtapps-[dev|user]@netlabs.org, but still no success. I don't know the reason. Maybe that's because they are not interested (they manually moderate all the requests, right?), or maybe because I didn't properly specify the mail list software installed on netlabs.org :) If you know how to make it working, you're welcome. Anyway, a better place to discuss this is qtapps-user()netlabs.org.

comment:5 Changed 12 years ago by guest

"Warp 3 can be marked as supported by Qt/2" - I'm not sure about this, Warp 3 _connect_ offered some convoluted upgrade paths for TCP/IP until I got the configuration shown above.

Yes, Peter told me that he got another ping about Psi/2 in a jabber chat... ;-) I've subscribed the lists at GMaNe again, that can take up to 4 weeks.

But obviously it worked for other netlabs lists including qt-dev. Maybe not qt-user, that's empty from my POV.

I've several questions, but they can wait until the list is available.

Frank (JID xyzzy AT ursine.ca)

Note: See TracTickets for help on using tickets.