#121 closed defect (fixed)

qpdfview can not print files with umlauts in file name

Reported by: andib Owned by: diver
Priority: Feedback Pending Component: qtapps
Version: Keywords:
Cc:

Description

qpdfview 0.4.16 with current netlabs-rel & netlabs-exp packages (running on heavily updated eCS2.1DE).

File names with umlauts can not be printed. F.i. trying to print _test_ü.pdf leads to a dialog "Warnung - Konnte >>T:/Temp/_test2_ü.pdf<< nicht drucken". File attached.

The same file copied to _test2.pdf prints fine.

Attachments (2)

_test2_ü.pdf (8.5 KB) - added by andib 17 months ago.
error_log.zip (14.8 KB) - added by andib 16 months ago.

Download all attachments as: .zip

Change History (10)

Changed 17 months ago by andib

comment:1 Changed 16 months ago by diver

please add a debug2 log from cups as well.

comment:2 Changed 16 months ago by andib

Maybe line 5515 will tell you something.

Changed 16 months ago by andib

comment:3 Changed 16 months ago by diver

  • Owner set to diver
  • Status changed from new to accepted

yes that's the reason it's not printing. I need to figure out if this is within cups already, or if cups gets kicked wrong from qpdfview.

comment:4 Changed 16 months ago by diver

  • Priority changed from major to Feedback Pending

please try new qpdfview.exe from http://rpm.netlabs.org/test/

comment:5 Changed 16 months ago by andib

After countless full hangs which needed the reset switch I can say this version can not even open a file. Best I can provide is -

{0}[p:\qpdfview] type log.txt

####### qPDFView 0.4.17    #######
 Date: 2018-06-19  Time: 20:07:49
##################################


Killed by SIGSEGV
pid=0x00b8 ppid=0x0034 tid=0x0001 slot=0x00d5 pri=0x0200 mc=0x0001 ps=0x0010
P:\QPDFVIEW\QPDFVIEW20180618.EXE
QTGUI4 0:00753fb5
cs:eip=005b:185a3fb5      ss:esp=0053:008eedd4      ebp=008eee0c
 ds=0053      es=0053      fs=150b      gs=0000     efl=00210206
eax=40b27400 ebx=2099b240 ecx=2095de40 edx=20030101 edi=20b19568 esi=20b19568
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

comment:6 Changed 16 months ago by diver

please try latest rpm in exp repo.

comment:7 Changed 16 months ago by andib

Yes this works. Thanks.

One regression in German translation - in "Datei" menu 'Save' and 'Save copy' are not translated anymore. The old 0.4.16 installation has translations for this two items too.

comment:8 Changed 16 months ago by diver

  • Resolution set to fixed
  • Status changed from accepted to closed

I moved it to rel and mark this as fixed. Some translations are missing I know. Those are added upstream already, but I did not sync them so far. When I have time I might do it.

Note: See TracTickets for help on using tickets.