Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#120 closed defect (fixed)

PSI v0.16-dev-20150213 - crashes when entering IM message

Reported by: darcio Owned by: Silvan Scherrer
Priority: Feedback Pending Component: psi
Version: Keywords:
Cc:

Description

I have been using PSI for a number of years. Some time ago I updated to 0.16.3, which was working quite nicely.

Recently however I discovered that as soon as I attmept to respond to an IM msg and start typing my response the app crashes. This only happens as I enter a response, the apps does not have a problem showing me the IM msg that was sent to me.

Through debugging all I have been able to determine is that as soon as the 2nd character of my response is being entered the app crashes, otherwise, if just a single character is entered it is fine.

I have not been able to narrow this down to anything else. All the pre-reqs listed in the readme are installed. My YUM/RPM uses the pentium4 platform.

Change History (9)

comment:1 Changed 2 years ago by Silvan Scherrer

Do you use latest psi from herehttp://trac.netlabs.org/qtapps/wiki/QT4%20Networking ?

comment:2 Changed 2 years ago by Silvan Scherrer

Priority: majorFeedback Pending

comment:3 Changed 2 years ago by andib

I've the same problem here. But only with the latest version from 'Date/Time?: 13 Feb 2015 13:42:17'.

The older version from 20141030 I used before worked well. Guess it's a problem with spell checking as it crashes at the second character.

Though I didn't have aspell / aspell-de installed before. Should we try to deinstall aspell?

Here's the crash report -

####### v0.16-dev 20150213 #######
####### Installed 20180522 #######
 Date: 2018-05-22  Time: 19:57:55
##################################

[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  795 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  795 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  795 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  7 
[19:57:56] Unknown signature value:  795 
[19:57:56] Unknown signature value:  7 
[19:57:56] unexpected version response
[19:57:58] W:PEPAvatar::setData(): Received data is empty. Bad encoding ?
[19:58:01] W:QWebInspector: QSettings couldn't read configuration setting [resourceTrackingEnabled].

Killed by SIGSEGV
pid=0x0183 ppid=0x0037 tid=0x0001 slot=0x009b pri=0x0200 mc=0x0001 ps=0x0010
P:\UTIL\PSI0.16\PSI.EXE
ASPELL15 0:0002b769
cs:eip=005b:179cb769      ss:esp=0053:00f6e97c      ebp=00f6e9ac
 ds=0053      es=0053      fs=150b      gs=0000     efl=00010246
eax=7ae5dbb0 ebx=00000249 ecx=206a7be2 edx=00000249 edi=209e0620 esi=209964a4
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

comment:4 Changed 2 years ago by Silvan Scherrer

Owner: set to Silvan Scherrer
Priority: Feedback Pendingcritical
Status: newaccepted

the good thing is I can reproduce it. If and when a fix is around depends on my time.

comment:5 Changed 2 years ago by Silvan Scherrer

Priority: criticalFeedback Pending

please test the new aspell rpm from exp repo. With this I can't reproduce the crash anymore

comment:6 Changed 2 years ago by Silvan Scherrer

any feedback?

comment:7 Changed 2 years ago by andib

Eventually I found the time to update both of my machines to exactly reproduce my test case. And for me now it works. Thanks.

comment:8 Changed 2 years ago by Silvan Scherrer

Resolution: fixed
Status: acceptedclosed

ok thx. I moved the aspell rpm now from exp to rel repo.

comment:9 Changed 2 years ago by darcio

Sorry I've dropped the ball on this ticket, I actually stopped using PSI because of this issue.

Having said that, I re-started and indeed, the issue went away following the install of the updated aspell package.

Therefore, I realize the ticket is already closed, but for what it's worth, that was the fix for the originally reported issue.

Thank you!

Note: See TracTickets for help on using tickets.