Opened 3 years ago

Closed 3 years ago

#116 closed defect (fixed)

BiblioteQ-2016.09.04-os2 multiple defects

Reported by: ak120 Owned by:
Priority: blocker Component: qtapps
Version: Keywords:
Cc:

Description

First problem is with documentation, following the yum/rpm route will not be successful. 3 DLL files are not available: *gcrypt20.dll *gpg-err0.dll *gtls28.dll

Also the zip instructions don't work. Please change in README.os2: libgpg-error-1.13.zip -> libgpg-error-1.18.zip libgcrypt-1.6.2.zip -> libgcrypt-1.6.3.zip which contain the correct DLL files and also mention that they will be required additionally to yum/rpm installation method.

Further the icon of the biblioteq.exe is garbled using this malformed book.ico from file book.ico.

But now the most critical, it's not possible to use the program to connect to any SQLite *.sqlite file.

There is only a message box "BiblioteQ: Database Error" that tells about not having a driver to connect. In this condition the program becomes totally useless.

Change History (7)

comment:1 Changed 3 years ago by Tellie

Thankz

I will look @ it asap

comment:2 Changed 3 years ago by ak120

I'm also using a yum/rpm install on another system to verify this behaviour. First I was thinking about a newer sqlite version from exp repo - but there's nothing.

comment:3 Changed 3 years ago by Tellie

Hi,

Is this SQLite database created by BIblioTeq?

More information is required. BiblioteQ will inform the user if the selected branch's database type does not have a driver associated with it. Are you attempting to access any SQLite database, like a database you created with another application?

comment:4 Changed 3 years ago by ak120

Of course thats the *.sqlite file created from biblioteq itself. But nothing works no access to files created by older version or a fresh created. The last working version was the 2016-02-17 which is crashing on every system the WPS because of wrong icon/EA of the executable.

comment:5 Changed 3 years ago by Tellie

I can confirm that the *.sqlite files don't work here.

But the 02-17 works fine here, no crash so far i tried it.

Ok, i think i found the problem, please remove the qt.conf or rename it

Then try again.

I reupload the BiblioteQ-2016.09.04-os2.7z

Last edited 3 years ago by Tellie (previous) (diff)

comment:6 Changed 3 years ago by ak120

Ok, now it works. The problem with 02-17 is only when opening the folder which contains the exe inside the WPS - from command line or any other method of calling there will be no problem. It's not a crash just freezing the system forever. By removing the EA and defect icon it works.

comment:7 Changed 3 years ago by Tellie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.