Opened 7 years ago

Closed 2 months ago

#250 closed task (wontfix)

Update to 5.x

Reported by: rudi Owned by:
Priority: major Milestone: Qt 5
Component: General Version:
Severity: low Keywords:
Cc:

Description

It looks like 4.7.4 is out...

Change History (9)

comment:1 Changed 7 years ago by dmik

  • Milestone changed from Qt 4.7 to Qt 4.next

Yes, a week ago or so. We won't do it now, as this may give more regressions and we don't want to delay any more. Qt 4.7.3 is good enough to finally have a release.

comment:2 Changed 7 years ago by dmik

Note that this will also include updating Qt Creator to 2.3.0.

comment:3 Changed 7 years ago by Tellie

It looks like 4.8.0 is out :)

comment:4 Changed 7 years ago by dmik

  • Summary changed from Update to 4.7.4 to Update to 4.8

Yes, saw that. We will update to 4.8.x right away instead of 4.7.4.

There seems to be some significant changes in some areas (e.g. file system support classes) so we should keep in mind that updating will require some platform-dependent work and won't be that fast.

comment:5 Changed 7 years ago by Tellie

Ok, good :)

Btw are the patches from Os2 send to nokia, so that we are official in the QT tree.

comment:6 Changed 6 years ago by diver

  • Summary changed from Update to 4.8 to Update to 5.x

as 4.8 is old also, we will go direct to 5.0

comment:7 Changed 4 years ago by dmik

BTW, I imported Qt 4.8.6 sources to vendor (http://trac.netlabs.org/qt4/browser/branches/vendor/digia/qt/4.8.6). We may decide to make an intermediate release soon.

comment:8 Changed 3 years ago by diver

  • Milestone changed from Qt 4.next to Qt 5

Milestone renamed

comment:9 Changed 2 months ago by diver

  • Resolution set to wontfix
  • Status changed from new to closed

work on Qt 5 has started some weeks ago. We hope to get enough sponsors to be able to get it done. Until now we still lack a lot money to complete it.

see https://github.com/bitwiseworks/qt5-os2 for more information.

Note: See TracTickets for help on using tickets.