Opened 8 years ago

Closed 8 years ago

#249 closed defect (fixed)

Qt Creator not painting it's main window interior

Reported by: rudi Owned by:
Priority: major Milestone: Qt 4.7
Component: QtGui Version:
Severity: medium Keywords:
Cc:

Description

When starting Qt Creator (DIVE mode, SNAP) the main window interior is not painted. The window has to be moved or resized manually in order to be drawn. This is most likely a regression of the recent changes in the drawing code.

Attachments (1)

painting_error.jpg (103.1 KB) - added by rudi 8 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by rudi

A similar issue can be observed with Qt Designer's "New Form" startup wizard. However, it doesn't happen always in this case.

Last edited 8 years ago by rudi (previous) (diff)

Changed 8 years ago by rudi

comment:2 Changed 8 years ago by dmik

Hmm, indeed. Actually, any application shows this problem in DIVE mode, even the textedit demo. Quick testing shows that r1019 is guilty. Strange...

comment:3 Changed 8 years ago by dmik

No, I cannot actually reproduce it with the current SVN and SNAP, I had some old build. Are you sure you did a complete rebuild?

I can reproduce it with Panorama though (only FB/FBSWM, BLIT mode doesn't show any problems), but Panorama is unable to correctly do Dive anyway, so it cannot be fully trusted here. We need somebody else with the real SNAP hardware to try this too.

comment:4 Changed 8 years ago by dmik

Hmm, really strange. The designer problem only shows up here if I reset QT_PM_DIVE. Setting it to either of FB/FBSWM/BLIT explicitly makes it work. It's strange because when QT_PM_DIVE is not set, it should behave exactly as if you do QT_PM_DIVE=FBSWM (on SNAP).

comment:5 Changed 8 years ago by dmik

It has something to do with timings as the problem doesn't always happen. Most of the time it works well with QT_PM_DIVE reset.

comment:6 Changed 8 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r1076. The variable initialization was missing which could incorrectly delay paint events in DIVE mode. That was a regression of the work I did for #203 indeed.

Thanks for reporting.

Note: See TracTickets for help on using tickets.