Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#235 closed defect (fixed)

Build process broken

Reported by: rudi Owned by:
Priority: blocker Milestone: Qt 4.7
Component: General Version:
Severity: low Keywords:


The changes r996 and r997 break the build process completely.

"mkdir-p.cmd" as well as "cd" don't get along well with quoted directory names and/or trailing backslashes.

Change History (4)

comment:1 Changed 7 years ago by dmik

Fuck, I really hate all this stupid ancient OS/2 crap tools like CMD.EXE do really require too much effort to support them. We should move to sh and friends ASAP.

Last edited 7 years ago by dmik (previous) (diff)

comment:2 Changed 7 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r1000.

It's not quoted names, it's the backslash. CMD.EXE's "cd" and "mkdir" commands can't deal with it.

BTW, you may report build break issues like that directly to my JID (dmik at dmik dot org) so that I can instantly fix them. Unfortunately, I can't test each qmake scenario to make sure there are no regressions (and not always think enough to predict those problems upfront).

Last edited 7 years ago by dmik (previous) (diff)

comment:3 Changed 7 years ago by rudi

"mkdir-p.cmd" works with trailing backslashes but falls over with the quotes. CMD.EXE's "cd" command does exactly the opposite.

It's absolutely clear to me that you can't test everything. Not to talk about the time a full build will take.

Last edited 7 years ago by rudi (previous) (diff)

comment:4 Changed 7 years ago by dmik

Yes, you are right, mkdir-p.cmd is capable of doing slashes (just because the code strips it before passing it to SysMkDir?() which can't tolerate them too). I also added support for quotes in r1002 as it was just simple (thanks to the Tokenize routine I have around for long) and important as long as we don't move to POSIX.

Last edited 7 years ago by dmik (previous) (diff)
Note: See TracTickets for help on using tickets.