Opened 8 years ago

Closed 8 years ago

#234 closed defect (fixed)

QtCreator's qmlpuppet doesn't get installed

Reported by: rudi Owned by:
Priority: major Milestone: Qt 4.7
Component: General Version:
Severity: low Keywords:
Cc:

Description

The utility qmlpuppet doesn't have an install target (multi-platform bug). In my case this caused it to be missing when building a binary distribution package. This caused Qt Creator to hang when switching back and forth between text graphical editors (QmlDesigner?).

Dmik, could you please check what happens in our QProcess implementation when the required executable is missing ? To me it looked like something in the pipes mechanic blocked, making Qt Creator unkillable.

Attachments (1)

qmlpuppet.diff (322 bytes) - added by rudi 8 years ago.
Add install target

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by rudi

Add install target

comment:1 Changed 8 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Applied your patch. Rudi, please report any further issues regarding Qt Creator here: https://github.com/dmik/qt-creator-os2/issues (a simple issue tracker was one of the reasons to choose github.com for hosting GITs after all).

Regarding QProcess. It fails with the "No such file or directory" error message. All pipes are closed, the pipe watcher thread is stopped. I checked my simple GUI and non-GUI test cases and they work as expected. I didn't have time to deep further though. Feel free to open a new Qt Creator issue (on github -) if you collect more information (e.g. an easy way to reproduce this).

Note: See TracTickets for help on using tickets.