Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#148 closed defect (invalid)

Assistant doesn't work anymore

Reported by: rudi Owned by:
Priority: major Milestone: Qt 4.6.2
Component: Tools Version: Unknown
Severity: low Keywords:
Cc:

Description

With the latest trunk, Assistant quit. The program just exists without showing even the slightest traces of a window. Just started a debug build. Maybe this will give some idea what might be wrong...

Change History (8)

comment:1 Changed 10 years ago by dmik

  • Resolution set to invalid
  • Status changed from new to closed

You need to make sure it can find and load the qsqlit4.dll plugin. If it cannot get the SQLite database driver, it prints a message to the console and exits, but in the release build the console is invisible so you don't get any feedback. I fixed it in r697 and now we get the GUI message box instead.

So, to get assistant work, you may need to rebuild both QtCore4.dll and plugins using the current SVN (there was one important fix: release applications could not find some release plugins and SQLite was one of them).

comment:2 Changed 10 years ago by rudi

Hmm, I rebuilt these. Assistant now gives a message saying that it cannot load the sqlite database driver. But that's it. Still no go for the release version. Debug version does start. However, it works only on one machine. On the other it dies with an exception in PMMERGE.

comment:3 Changed 10 years ago by dmik

The PMMERGE exception was already fixed yesterday (check the timeline). And the fact it still doesn't work means the plugins are wrong (were not rebuilt for some reason) on your system. Please do a clean checkout and build again, then delete %USER%/.config and try again.

P.S. It's easy to check if the plugin is ok or not: first, you may look to D:\Users\dmik\.config\Trolltech.ini where it prints the versions and build keys of all plugins it could find. Then you can also search the plugin DLLs for "g++" to see what's actually inside the gien DLL. The build key string looks like this

os2 g++-4 release full-config QT_NO_DBUS QT_NO_DECLARATIVE...

And it should match the one in QtCore4.dll (together with the Qt version) in order for plugins to be treated as compatible.

comment:4 Changed 10 years ago by rudi

Well, the buildkey in the plugins as well as the information in trolltech.ini looks O.K. However, my release version of QtCore4 (just rebuilt completely) contains the "debug" signature.

comment:5 Changed 10 years ago by rudi

O.K., it looks like a new run of "configure.cmd" was required. Now that I have done that, a new version of corelib\global\qconfig.h has been created, that looks somewhat different (better?)... Will see, what happens when the build is complete.

comment:6 Changed 10 years ago by dmik

Ah you didn't run configure.cmd? That was not right. Now it will work.

comment:7 Changed 10 years ago by rudi

Well, you didn't say that this is necessary...

comment:8 Changed 10 years ago by dmik

This is the first thing that you should normally do after svn update, so just memorize that.

Note: See TracTickets for help on using tickets.