Opened 10 years ago

Closed 10 years ago

#104 closed defect (wontfix)

Systray widget display problem

Reported by: chennecke Owned by:
Priority: minor Milestone: Qt Beta 5
Component: General Version:
Severity: Keywords:
Cc:

Description

Once added to the XCenter, the extended systray widget is not visible at all if no application is loaded that uses it. It has a zero width. This is bad for two reasons:

  • There is not visual feedback that it has been added to the XCenter correctly.
  • It cannot be removed from the XCenter the standard way by right clicking on it and selecting "Remove widget", only via the XCenter properties notebook.
  • Setting possible properties would only possible via the XCenter properties notebook.

What about using a minimum width of one icon?

Change History (2)

comment:1 Changed 10 years ago by dmik

It actually has a width of 4 pixels when empty but I agree that it's near to impossible to hit it with the mouse. However, I don't agree with you to consider this behavior as a bug because:

  1. Even if it had a minimum width that would allow clicking it when empty, the user who prefers the XCenter style w/o separators and w/o frames around static contents, would not notice its existence anyway.

Also, I believe that this plugin provides the functionality which is a must nowadays, and hence should be integrated into XCenter itself like other mission critical plugins such as Window List or Time. I will propose this to the XWorkplace development team very soon. Once it's part of XCenter, you will most likely not need to install it as it will be present by default.

  1. All kinds of clicks (including the Context menu event) are unconditionally directed to the application owning the icon, by design. So, getting the user access to the xsystray own context menu when it is empty and not letting do so when it's filled with icons is a bogus and confusing behavior.

More over, if xsystray becomes part of XCenter, it will be possible to integrate its future settings dialog into the XCenter settings dialog as a separate Tab for example. Which will be quite logical and simple to use (the XCenter context menu is usually easily available).

What about the way to remove (and even move!) the plugin using the widget list in the XCenter settings notebook, I find this possibility really smart and handy, I miss it on Ubuntu where you have to work hard if you want to manipulate the widgets on the panel. Keeping in mind that we have such a great feature, the problems you mention are not actually problems :)

The only thing in my opinion that would improve usability indeed is informing the user that he should manipulate the xsystray plugin using the XCenter settings notebook. This can be done in a suppressable message box shown at XCenter startup.

comment:2 Changed 10 years ago by dmik

  • Resolution set to wontfix
  • Status changed from new to closed

No feedback from the reporter, I'm considering that you agree to my arguments.

Note: See TracTickets for help on using tickets.