Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#203 closed defect (invalid)

klibc returns current directory instead of root

Reported by: Shmuel (Seymour J.) Metz Owned by:
Priority: minor Milestone:
Component: *none Version:
Severity: low Keywords: root, current, directory
Cc:

Description

I ran into a problem with the p7zip command 7za w:\temp\M.7z M:\ (mentioned in https://www.os2world.com/forum/index.php?topic=1941.0) attempting to archive an entire volume and reported it to Ruediger Ihle and he responed:

I did some more testing and it turns out the klibc is the culprit! The problem is, that when the functions opendir()/readdir() are asked to retrieve the content of a root directory (i.e. "X:/*"), they erroneously return the content of the *current* directory on that drive.

Note: I gave this a low priority because I've been able to bypass my problems with zip, and it runs faster than p7zip. However, I can't guaranty that it's not important to other customers running into the same problem in a different application.

Change History (3)

comment:1 Changed 13 months ago by Silvan Scherrer

Resolution: invalid
Status: newclosed

Thats the wrong Project to Report this error. Rüdiger opend it at the right Project. So i close this.

Last edited 13 months ago by Silvan Scherrer (previous) (diff)

comment:2 Changed 13 months ago by Shmuel (Seymour J.) Metz

What is the correct project and ticket number so I can check the status?

Note: See TracTickets for help on using tickets.