Opened 3 years ago

Closed 2 years ago

#155 closed enhancement (fixed)

create a rpm for the bjnp cups backend

Reported by: losepete Owned by: Silvan Scherrer
Priority: major Milestone:
Component: cups Version:
Severity: medium Keywords:
Cc:

Description

cups 2.1.3-7

Attempting to print the cups Test Page from the browser interface fails which displays "Filter failed".

I killed cupsd and opened the log with a text editor - I did try opening the error log from the Admin page of the browser interface but and unknown username/password combination is required.

The log indicates the print job failed due to "gstoraster stopped with status 11."

Attachments (1)

Job2_error_log (140.7 KB) - added by losepete 3 years ago.
error_log: "filter failed" "gstoraster stopped with status 11

Download all attachments as: .zip

Change History (18)

comment:1 Changed 3 years ago by Silvan Scherrer

Component: *nonecups
Owner: set to Silvan Scherrer
Priority: blockerFeedack pending
Status: newaccepted

how should one know what's going on on your system, if you don't attach the logfile.

Changed 3 years ago by losepete

Attachment: Job2_error_log added

error_log: "filter failed" "gstoraster stopped with status 11

comment:2 Changed 3 years ago by losepete

Apologies, Please find attached Job2_error_log created with LogLevel? set at debug

comment:3 Changed 3 years ago by Silvan Scherrer

I looked at the log and saw

Started backend /@unixroot/usr/lib/cups/backend/bjnp.exe (PID 320)

now I wonder a bit where this backend is coming from. As I can't remember this is a rpm installable backend.

comment:4 Changed 3 years ago by losepete

The bjnp.exe backend is a necessity as is the cups17.dll support file so these files were manually installed in order to test whether they would work with the rpm packaged cups - there is not an rpm packaged build of bjnp.exe anywhere that I could find.

Sadly we have not yet got to the stage of testing whether bnjp will work - unless you think that having bjnp.exe running is causing the gstoraster resource deadlock?

comment:5 Changed 3 years ago by Silvan Scherrer

the issue is that bnjp is not running as it should. and it can't, as it uses a different cups.dll. If I interpret the log right, gstoraster sends data to bnjp, but this one doesn't know what to do with it.
Doesn't gutenprint support your printer?

And for your info it is not a resource deadlock, it's just a exit(11).

comment:6 Changed 3 years ago by Silvan Scherrer

and btw which os2-base rpm do you have installed?
yum list os2-base* shows you the info.

comment:7 Changed 3 years ago by losepete

Yes, bjnp.exe needs cups17.dll rather than cups.dll

Hopefully the rpm gutenprint supports the Canon MG7550 - installing gutenprint does allow me to select the MG7550 when creating a printer.

If this build of bjnp.exe cannot work with the rpm build of cups then the rpm build of cups is absolutely no use to anyone with a recent/current Canon inkjet printer using the bjnp port (ip over usb I believe) until a compatible build of bjnp.exe is available. Are there plans to make this backend available in the near future?

I may have misunderstood a response on os2world.com:-

11 should be the value of errno.
From /usr/include/sys/errno.h
#define EDEADLK 11 /* Resource deadlock avoided */

So, an exit to avoid a resource deadlock rather than a resource deadlock?

ANPM shows os2-base 0.0.0-14(c00)

comment:8 Changed 3 years ago by Silvan Scherrer

this has completely nothing to do with a resource deadlock. but anyway that's not the issue.
please also try to update to latest os2-base, as it includes some config.sys changes which could help.

And I have absolutely no idea what this bjnp is about. If you find the reference to the current source we might consider a rpm port of it.

comment:9 Changed 3 years ago by losepete

Updated os2-base to 0.0.0-15(c00) and rebooted. No change to the gstoraster problem.

bjnp - possibly stands for bubble jet network printer - is needed for Canon printers using the proprietary USB over IP BJNP protocol. This is needed by most, if not all, current/recent Canon inkjet printers; Without it printing cannot happen.

The cups port is here https://sourceforge.net/projects/cups-bjnp/

comment:10 Changed 3 years ago by Silvan Scherrer

ok I will consider porting it and create a rpm. The issue is I can't test it as I don't have such printers.

comment:11 Changed 3 years ago by Silvan Scherrer

please give me also the output of:

sh -c "gs"

to end gs just type quit

comment:12 Changed 3 years ago by losepete

Output of sh -c "gs":-

[F:\]sh -c "gs"
GPL Ghostscript 9.18 (2015-10-05)
Copyright (C) 2015 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
GS>quit

[F:\]

comment:13 Changed 3 years ago by Silvan Scherrer

Priority: Feedack pendingmajor
Summary: gstoraster stopped with status 11create a rpm for the bjnp cups backend
Type: defectenhancement

as we handle the gstoraster in #157, I change this description to the port request for bjnp

comment:14 Changed 3 years ago by Silvan Scherrer

comment:15 Changed 3 years ago by Silvan Scherrer

rpm is uploaded to netlabs exp repo. as this is done I need urgently to find the gstoraster/gs issue

comment:16 Changed 3 years ago by Silvan Scherrer

any news on that with latest cups, cups-filters and gs rpm versions?

comment:17 Changed 2 years ago by Silvan Scherrer

Resolution: fixed
Status: acceptedclosed

hmm no more news, so closing it

Note: See TracTickets for help on using tickets.