Opened 13 years ago

Closed 13 years ago

#51 closed defect (fixed)

LUGBM.DLL access violations on BMP, JPEG graphics

Reported by: edurrant@… Owned by: eros2
Priority: major Milestone:
Component: Lucide Core Version: 1.0 Beta 2
Keywords: Cc:

Description

Whereas Lucide v 2.0 Beta appears to work a lot better opening PDF files, unfortunately it appears to now have a problem opening graphics files.

I have tried opening BMP files (handled I expect by the GBM Plugin) and Jpeg files (handled I hope by the JPG plugin) and in all cases the program aborts and reports an access violation in LUGBM.DLL.

Upon testing, by moving GBM.DLL once again out of the working directory and trying to open the JPEG file again - it opens without problems, so I start to suspect that there may be a compatibility between the GBM plugin and version Beta2 of Lucide ?

Ed.

Change History (8)

comment:1 Changed 13 years ago by anonymous

  • Milestone 2.0 and further deleted
  • Version set to 1.0 Beta 2

comment:2 Changed 13 years ago by ktk

Can you please try to update the GBM dll? There should be a new one available at Heikos homepage

comment:3 Changed 13 years ago by eros2

Beta 2 require updated gbm plugin. I guess it doesn't released yet, maybe later today...

comment:4 Changed 13 years ago by edurrant@…

Thanks - as soon as I can get the new version of the GBM plugin, I'll try it with Beta 2 to check if both the Open dialogue and BMP/JPG issues have been resolved and report back.

Ed.

comment:5 Changed 13 years ago by Heiko

The updated GBM plugin compatible with the new Lucide release is not yet released. The old one doesn't work anymore due to API changes.

I'll soon release the updated version. Stay tuned...

Heiko

comment:6 Changed 13 years ago by edurrant@…

Ok, thanks

comment:7 Changed 13 years ago by Heiko

The updated GBM plugin that is compatible with Lucide beta 2 is now available. Checkout http://heikon.home.tlink.de and Hobbes incoming.

Please check if your problems are gone now and if so, close this ticket as fixed.

comment:8 Changed 13 years ago by edurrant@…

  • Resolution set to fixed
  • Status changed from new to closed

Yes I can confirm the latest LUGBM.DLL plugin with the latest GBM.DLL (both downloaded from your recent uploads to Hobbes Incoming - I could not find the correct version on your website) solves the access violation problems - thanks.

Regards, Ed.

Setting this ticket to closed.

Note: See TracTickets for help on using tickets.