Opened 13 years ago

Closed 13 years ago

#50 closed defect (worksforme)

Application exits after attempt to open .PDF or .JPG

Reported by: TheRealPhil Owned by: eros2
Priority: major Milestone: Beta 4
Component: Lucide Core Version: 1.0 Beta 2
Keywords: exit PDF JPG Cc:

Description

The application start up okay. I can navigate through the menus. Howeve, after clicking Document-Open and then selecting [PDF or JPG file] followed by OK, the application exits.

There are no error messages and no POPUPLOG.OS2 file. This is the same for all versions of LUCIDE; that is, v1.0, v1.1 and v2.0.

Since I have a couple of compilers, it's possible that my SOM paths and files are missing or nonstandard. What SOM files and what SOM paths are required by LUCIDE? Currently, I have tried to separate the SOM stuff from Visualage C++ v3.09; from the Warp Toolkit v4.52; and from the eCS v1.1 base into their appropriate sections.

That is the only thing I can think of that might be causing the problem.

Is there a debug mode for LUCIDE?

Sorry, but I'm kind of stuck!

Attachments (2)

chkdll32.zip (27.7 KB) - added by eros2 13 years ago.
stdout.txt (5.7 KB) - added by TheRealPhil 13 years ago.
STDOUT from chkdll32 -! Lucide results

Download all attachments as: .zip

Change History (21)

comment:1 Changed 13 years ago by anonymous

  • Milestone Beta 2 deleted
  • Version set to 1.0 Beta 2

comment:2 Changed 13 years ago by eros2

Very mysterious...

Try to execute lucide from command line using command like:

lucide >stdout 2>stderr

After lucide exit check if stdout/stderr files contains something.

comment:3 Changed 13 years ago by TheRealPhil

Nice, a possible solution!

stdout gives

Error: class <SOMObject> version mismatch

(version compatible with (1,5) requested by caller, but version (1,4) is provided by the class's implementation)

Error: Attempt to load, create or use an incompatible class. "SOM.C": 1364: SOM Error - code = 2-007-9, severity = Fatal.

The SOM paths I generally use is in this order: ecs basic, Warp Toolkit and VACPP. I would guess some file got deleted or renamed and an older version is used. Does the error message give you enough infomation to narrow down the name of the file(s)?

Thank you for your help!

Changed 13 years ago by eros2

comment:4 Changed 13 years ago by eros2

Well, at least now we definitely know - problem due to SOM version mismatch...

I unsure about which files may cause this... I attached chkdll utility, please run it against lucide.exe.

For me, it shows output like:

D:\Projects\lucide\trunk\Lucide\BIN>chkdll32.exe Lucide.exe
Loading DLL 'som' --> C:\OS2\DLL\SOM.DLL.
Loading DLL 'LUDOC' --> D:\PROJECTS\LUCIDE\TRUNK\LUCIDE\BIN\LUDOC.DLL.
Loading DLL 'DOSCALLS' --> loaded.
Loading DLL 'NLS' --> C:\OS2\DLL\NLS.DLL.
Loading DLL 'PMWIN' --> C:\OS2\DLL\PMWIN.DLL.
Loading DLL 'PMSHAPI' --> C:\OS2\DLL\PMSHAPI.DLL.
Loading DLL 'PMCTLS' --> C:\OS2\DLL\PMCTLS.DLL.
Loading DLL 'PMGPI' --> C:\OS2\DLL\PMGPI.DLL.
Loading DLL 'PMDRAG' --> C:\OS2\DLL\PMDRAG.DLL.
All DLL's used by 'Lucide.exe' could be loaded.

So, we can see which DLLs is loaded.

You may also use option '-!' which lists all DLLs recursively.

Changed 13 years ago by TheRealPhil

STDOUT from chkdll32 -! Lucide results

comment:5 Changed 13 years ago by TheRealPhil

Using "chkdll32.exe Lucide.exe" gives me the exact results you get.

However, using "chkdll32.exe -! Lucide.exe" does give me a STDERR that says "File is not a valid OS/2 .EXE or .DLL file". It doesn't say what file, though.

The STDOUT is attached as stdout.txt for your examination.

Thank you for your time!

PS. In the future, should I zip all these type of text files before attaching them?

comment:6 Changed 13 years ago by eros2

I have no guess whats wrong...

Please check dates of SOM DLLs in \OS2\DLL, maybe them was replaced? Compare with files from CD.

comment:7 Changed 13 years ago by eros2

Check also SET SOMIR and SET SOMDDIR lines in CONFIG.SYS, them should looks like -

SET SOMIR=C:\OS2\ETC\SOM.IR;C:\OS2\ETC\WPSH.IR;C:\OS2\ETC\WPDSERV.IR;C:\OS2\ETC\REXX.IR;
SET SOMDDIR=C:\OS2\ETC\DSOM

If any additional entried listed - try to remove them.

comment:8 Changed 13 years ago by Rudi

I had exactly the same problem. The cause here was that the IBM C3.65 compiler comes with some really outdated SOM.DLL. Due to the LIBPATH set by the default installation of the product, the system will load this one instead of the one in \OS2\DLL. The WPS itself seems to work correctly with the old DLL, bit Lucide does not.

comment:9 Changed 13 years ago by Heiko

The same as described by Rudi applies to IBM VAC 3.0.

After installing VAC move all entries made to variables in CONFIG.SYS to the end (PATH, DPATH, HELP, LIBPATH, SOMIR). The OS/2 paths must be before the VAC paths everywhere. This will also make your WPS more stable.

I have moved the OS/2 Toolkit 4.5x paths behind the OS/2 paths as well although this shouldn't cause any problem.

comment:10 Changed 13 years ago by TheRealPhil

i wouldn't mind if Rudi, when he has a moment, can do a

bldlevel c:\os2\dll\som.dll

on his version of this file. The one on my system seem to be the correct one, but may be I'm picking up a rogue version somewhere else.

comment:11 Changed 13 years ago by Heiko

The som.dll has no embedded version number on all of my systems (eCS 1.15 with VAC 3.08, plain eCS 1.2MR).

Both systems show the following dir attributes:

30.06.99 16.33 92.009 0 a--- SOM.DLL

(German date, simply swap the first 2 numbers for English format)

BTW, I hope you don't have the old version of my GBM plugin still in the Lucide installation directory. This might also create this strange behaviour. Try deactivating all plugins except for instance lupplr.dll. Maybe this helps reducing the trouble scope.

comment:12 Changed 13 years ago by TheRealPhil

Heiko, is the old version of your GBM plugin under a different name than your current version? Otherwise, no go but it was a good try.

Thank you for your suggestion.

I think it is likely the only ones to have this problem are some people who install the Warp Toolkit and/or an IBM Visualage C++ for OS/2.

comment:13 Changed 13 years ago by Heiko

No change, the plugin kept the initial name.

Well, I have the Warp Toolkit 4.52, VAC 3.08 and OpenWatcom? installed. Lucide works fine here. I can even debug my plugin with the VAC debugger attached to Lucide.

So it must be something related to your installation.

comment:14 Changed 13 years ago by Jan

  • Milestone set to Beta 2

I have thw same problem to open PDF and jpg files. In the popuplog.os2> 08-12-2006 19:08:57 SYS3175 PID 0067 TID 0003 Slot 00a8 F:\PROGRAMS\LUCIDE\LUCIDE.EXE c0000005 1d6139c9 P1=00000001 P2=00000000 P3=XXXXXXXX P4=XXXXXXXX EAX=00000000 EBX=1817aea4 ECX=ffffffff EDX=00000000 ESI=0495fc64 EDI=00000000 DS=0053 DSACC=f0f3 DSLIM=ffffffff ES=0053 ESACC=f0f3 ESLIM=ffffffff FS=150b FSACC=00f3 FSLIM=00000030 GS=0000 GSACC= GSLIM= CS:EIP=005b:1d6139c9 CSACC=f0df CSLIM=ffffffff SS:ESP=0053:0495f8c4 SSACC=f0f3 SSLIM=ffffffff EBP=04650ef0 FLG=00012246

LUPPLR.DLL 0002:000139c9

comment:15 Changed 13 years ago by JuergenUlbts

Hi!

I've added the popuplog.os2 entry to bug #55 and attached the PDF file. Maybe my error is also releated to Toolkit45 and IBM VAC 3.x! I've just checked my LIBPATH, PATH,... settings and the Toolkit45 and IBMCPP entries follow the standard OS2/eCS entries. Does anyone know how "SET SOMBASE=... and SET SOMRUNTIME=..." which are currently pointing to the Toolkit may influence this?

Just tried Beta 1.1 again and it loads the file, but most stuff isn't displayed, so I assume it's not a SOM problem on my side.

comment:16 Changed 13 years ago by ktk

  • Milestone changed from Beta 2 to Beta 4

Moved to beta 4

comment:17 Changed 13 years ago by eros2

TheRealPhil?, please show you LIBPATH entry in config.sys. And also 'dir' command output in \OS2\DLL directory...

comment:18 Changed 13 years ago by eros2

Jan, please try this - http://os2.in.ru/download/eros2/lucide_test_frank.zip - it should fix your crash.

comment:19 Changed 13 years ago by eros2

  • Resolution set to worksforme
  • Status changed from new to closed

No feedback for >1 month, closed. Reopen if needed.

Note: See TracTickets for help on using tickets.