Opened 13 years ago

Closed 13 years ago

#55 closed defect (fixed)

Trap in LUPPLR.DLL

Reported by: pr Owned by: eros2
Priority: blocker Milestone:
Component: Lucide Core Version: 1.0 Beta 2
Keywords: Cc:

Description

Happened when I tried opening a file. Of course, it doesn't do it reproducibly and I can't remember which file it was now...

07-18-2006  09:03:20  SYS3175  PID 4bcd  TID 0002  Slot 00e3
F:\OS2APP\LUCIDE\LUCIDE.EXE
c0000005
14a1b385
P1=00000002  P2=fffffb03  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=000000c1  EBX=00000000  ECX=000001a9  EDX=fffffb03
ESI=008b47e8  EDI=ffffffff  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:14a1b385  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0088f9d8  SSACC=f0f3  SSLIM=ffffffff
EBP=14abd0a4  FLG=00012202

LUPPLR.DLL 0002:0007b385

Attachments (1)

ClassForName.zip (36.9 KB) - added by JuergenUlbts 13 years ago.
PDF file causing a SYS3175 trying to open the file with Lucide Beta2

Download all attachments as: .zip

Change History (5)

comment:1 Changed 13 years ago by JuergenUlbts

  • Priority changed from minor to blocker

This happens on every PDF file I tried to open so far. One PDF ("ClassForName?")is attached. I've removed the previous version, installed the WPI package and restarted the desktop (not the complete system). Previous versions did work!

08-15-2006  16:39:44  SYS3175  PID 0064  TID 0003  Slot 00a1
D:\OS2TOOLS\EDITOREN\LUCIDE\LUCIDE.EXE
c0000005
179d39c9
P1=00000001  P2=00000000  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000000  EBX=17adaea4  ECX=ffffffff  EDX=00000000
ESI=02a6fc64  EDI=00000000  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:179d39c9  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:02a6f8c4  SSACC=f0f3  SSLIM=ffffffff
EBP=02a84fb0  FLG=00012246

LUPPLR.DLL 0002:000139c9

Changed 13 years ago by JuergenUlbts

PDF file causing a SYS3175 trying to open the file with Lucide Beta2

comment:2 Changed 13 years ago by eros2

I doesn't have any problems with your file. Please check if beta 3 still crashes.

comment:4 Changed 13 years ago by JuergenUlbts

  • Resolution set to fixed
  • Status changed from new to closed

Hi, sorry I didn't report back but I haven't looked for an answer. The latest Beta 4 (2006-10-16?) does work without crashing here, so I changed it to "fixed". Thank you! I'll stay with GSView + Ghostscript most of the time because of it's "auto reload on file change" function, but as Adobe Acrobat Reader replacement it's usable and fast.

Juergen

Note: See TracTickets for help on using tickets.