Opened 13 years ago

Closed 13 years ago

#32 closed defect (fixed)

libc: readdir_r returns -1 instead of errno

Reported by: bird Owned by: bird
Priority: normal Milestone: libc-0.6.1
Component: libc-frontend Version: 0.6
Severity: normal Keywords: libc readdir_r
Cc:

Description

Title says it all.

Change History (2)

comment:1 Changed 13 years ago by bird

This typically happens when we're hitting a no-more-file condition. Such a condition should be indicated by setting *ppResult to NULL not by error.

comment:2 Changed 13 years ago by bird

  • Resolution set to fixed
  • Status changed from new to closed

There was already a todo comment on the problem. I've just changed it to return 0 instead of -1 when no more files are available. The problem is gone and my testcase works.

Note: See TracTickets for help on using tickets.