Opened 13 years ago

Closed 8 years ago

#29 closed defect (wontfix)

Seriously odd g++ error trying to include os2emx.h from os2.h

Reported by: bird Owned by: bird
Priority: normal Milestone: libc-0.6.4
Component: gcc Version: 0.6
Severity: normal Keywords: gcc libc
Cc:

Description

In file included from ../../dist/include/xpcom/plevent.h:204,
from ../../dist/include/xpcom/nsIEventTarget.h:17,
from ../../dist/include/xpcom/nsIEventQueue.h:10,
from D:/builds/nightlies/thunderbird/mozilla/layout/generic/nsSelection.cpp:97:
C:/GCC335/include/os2.h:35:79: C:/GCC335/include/os2emx.h: Invalid argument
In file included from ../../dist/include/xpcom/nsIEventTarget.h:17,
from ../../dist/include/xpcom/nsIEventQueue.h:10,
from D:/builds/nightlies/thunderbird/mozilla/layout/generic/nsSelection.cpp:97:
../../dist/include/xpcom/plevent.h:550: error: parse error before `*' token
make.exe[5]: *** [nsSelection.o] Error 1
make.exe[5]: Leaving directory `D:/builds/nightlies/thunderbird/mozilla/obj/layout/generic'
make.exe[4]: *** [libs] Error 2
make.exe[4]: Leaving directory `D:/builds/nightlies/thunderbird/mozilla/obj/layout'

Change History (5)

comment:1 Changed 13 years ago by bird

it doesn't appeares to be related to #22 since that only happens if writing is denied and has a different error code than what this appears to be (EINVAL).

comment:2 Changed 13 years ago by bird

  • Milestone changed from libc-0.6.1 to libc-0.6.2

Since I've no idea how to reproduce this yet, we'll see if it goes away with #21 or some of the other changes and delay further investigation to 0.6.2.

comment:3 Changed 12 years ago by bird

  • Milestone changed from libc-0.6.2 to libc-0.6.3

comment:4 Changed 11 years ago by bird

  • Milestone changed from libc-0.6.3 to libc-0.6.4

comment:5 Changed 8 years ago by bird

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.