Opened 7 years ago

Closed 6 years ago

#249 closed defect (duplicate)

LIBC extended attributes can cause non-EAs aware applictions to fail

Reported by: stevenhl Owned by: bird
Priority: high Milestone: libc-0.6.5
Component: libc-backend Version:
Severity: normal Keywords:
Cc:

Description

LIBC marks the Extended Attributes used to support unix file attribute emulation as critical (FEA_NEEDEA). This prevents non-EA aware applications from opening these files on HPFS formatted volumes.

The particular use-case was that a user ran some application that applied LIBC EAs to uhpfs.dll. Format.com reported

SYS1311: The system files are missing.

because the DosLoadModule?() libpath search failed to find a uhpfs.dll that could be opened.

Note that this issue does not affect jfs formatted volumes. It appears that jfs.ifs does not check if the application supports EAs.

Change History (1)

comment:1 Changed 6 years ago by bird

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #248.

Note: See TracTickets for help on using tickets.