Opened 11 years ago

Closed 8 years ago

#211 closed defect (worksforme)

sigfpe in strtod

Reported by: psmedley Owned by: bird
Priority: normal Milestone: libc-0.6.5
Component: libc-frontend Version: 0.6.2
Severity: normal Keywords: strtod
Cc:

Description

The code fragment at http://markmail.org/message/gcjqlo2dquprrt2h

ie #include <stdlib.h>

int main(void) { strtod("5e-324", NULL);

return (0); }

also causes a SIGFPE in strtod in klibc 0.6.3 - probably as the strtod is based on freebsd?

Change History (4)

comment:1 Changed 11 years ago by psmedley

Interestingly, which the code above crashes for me and others on eCS v2, it does run to completion on ACP for two other users - so potentially this is an eCS v2 issue

comment:2 Changed 11 years ago by psmedley

test code built with libc05 also works

comment:3 Changed 9 years ago by bird

  • Component changed from baselayout to libc-frontend
  • Status changed from new to assigned

comment:4 Changed 8 years ago by bird

  • Resolution set to worksforme
  • Status changed from assigned to closed

Cannot reproduce. Tried two machines no SIGFPE.

Note: See TracTickets for help on using tickets.