Opened 11 years ago

Closed 8 years ago

#200 closed defect (fixed)

libc: stat on symlink returns garbage

Reported by: bird Owned by: bird
Priority: normal Milestone: libc-0.6.4
Component: libc-backend Version: 0.6.2
Severity: normal Keywords: lstat
Cc:

Description

Title says it all.

Change History (6)

comment:1 Changed 11 years ago by psmedley

  • Summary changed from libc: lstat on symlink returns garbage to libc: stat on symlink returns garbage

Correction to title - lstat works OK - stat is broken

comment:2 Changed 9 years ago by bird

  • Status changed from new to assigned

comment:3 Changed 8 years ago by bird

(In [3725]) 200-stat-symlink.c: added stat/lstat+symlink testcase. References #200.

comment:4 Changed 8 years ago by bird

(In [3726]) b_nativeSymlinkCreate.c: Symlinks were created on byte to long. References #200.

comment:5 Changed 8 years ago by bird

(In [3727]) 0.6: Backported r3726: b_nativeSymlinkCreate.c: Symlinks were created on byte to long. References #200.

comment:6 Changed 8 years ago by bird

  • Resolution set to fixed
  • Status changed from assigned to closed

Couldn't reproduce, only a tiny off by one st_size bug when creating symlinks.

Note: See TracTickets for help on using tickets.