Opened 12 years ago

Closed 12 years ago

#135 closed defect (fixed)

libc: setlocale(LC_COLLATE, "C") doesn't work correctly

Reported by: bird Owned by: bird
Priority: normal Milestone: libc-0.6.2
Component: libc Version: 0.6
Severity: major Keywords: setlocale strcoll
Cc:

Description

The character weights aren't correct after doing setlocale(). This breaks gnu sed among other things because strcoll() returns incorrect results (like "b" is less than "a" and similar nonsense).

Change History (1)

comment:1 Changed 12 years ago by bird

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce the problem after setlocale here but I found a problem in the default collate info that I've fixed. Will reopen the problem reoccurs.

Note: See TracTickets for help on using tickets.