Opened 9 years ago

Closed 9 years ago

#76 closed defect (worksforme)

Java Sound API Frist test jar failed

Reported by: Rainer Owned by:
Priority: minor Milestone:
Component: general Version: 1.6.0-b19 RC
Severity: low Keywords:
Cc:

Description

http://java.sun.com/products/java-media/sound

http://www.oracle.com/technetwork/java/index-139508.html

I have downloaded the file and test the apps with GC Java 1.4.1_07 and Innotekt Java 1.4.2_05 about 2005 / 2006.

Now tested the first java app "CapturePlayback?" with the RC.

  1. The Window of the app is display
  1. press the load bottom

result:

[S:\CMD-PROC]java -version
openjdk version "1.6.0-rc"
OpenJDK Runtime Environment (build 1.6.0-rc-b19)
OpenJDK Client VM (build 16.0-b13, mixed mode)

[S:\CMD-PROC]java -cp s:\download\java\jsound\javasounddemo\JavaSoundDemo?.jar Ca
pturePlayback

[S:\CMD-PROC]java -cp s:\download\java\jsound\javasounddemo\JavaSoundDemo?.jar Ca
pturePlayback
java.lang.RuntimeException?: java.io.IOException: Could not get shell folder ID l
ist

at sun.awt.shell.Win32ShellFolder2$ComTask?.execute(Win32ShellFolder2.jav

a:1258)

at sun.awt.shell.Win32ShellFolder2.getFileSystemPath(Win32ShellFolder2.j

ava:579)

at sun.awt.shell.Win32ShellFolderManager2.getPersonal(Win32ShellFolderMa

nager2.java:155)

at sun.awt.shell.Win32ShellFolder2$10.call(Win32ShellFolder2.java:678)
at sun.awt.shell.Win32ShellFolder2$10.call(Win32ShellFolder2.java:665)
at java.util.concurrent.FutureTask?$Sync.innerRun(FutureTask?.java:334)
at java.util.concurrent.FutureTask?.run(FutureTask?.java:166)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.

java:1110)

at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?

.java:603)

at sun.awt.shell.Win32ShellFolder2$ComTaskExecutor?$3.run(Win32ShellFolde

r2.java:1214)

at java.lang.Thread.run(Thread.java:636)

Caused by: java.io.IOException: Could not get shell folder ID list

at sun.awt.shell.Win32ShellFolder2.getFileSystemPath0(Native Method)
at sun.awt.shell.Win32ShellFolder2.access$1000(Win32ShellFolder2.java:75

)

at sun.awt.shell.Win32ShellFolder2$8.call(Win32ShellFolder2.java:581)
at sun.awt.shell.Win32ShellFolder2$8.call(Win32ShellFolder2.java:579)
at sun.awt.shell.Win32ShellFolder2$ComTask?.execute(Win32ShellFolder2.jav

a:1249)

... 10 more

Kind Regards

Rainer

Change History (6)

comment:1 Changed 9 years ago by Rainer

testet the application with VPC XP Guest and SUN Java RJE 1.6.0_24.

No problem, pressing the load bottom and the window "OPEN" for file selection pops up.

Kind regards

Rainer

comment:2 Changed 9 years ago by Rainer

and here is the command file - documenting the test environment OS/2 MCP2 CP5
for executing Java 1.6 tests

rem Command file: java16.cmd
rem
rem Function: Set the environment for Java 1.6 RC
rem
rem Start the cmd via WPS Program Object with
rem
rem Path and File Name : *
rem Parameter : /K JAVA16.cmd
rem Working Directory : S:\CMD-PROC
rem
rem
rem
rem History:
rem 2011-02-23 Rainer creation

mode 80,80

SET LIBPATHSTRICT=T

SET BEGINLIBPATH=S:\download\os2\gcc444;S:\download\os2\libc063;S:\odin\system32;s:\download\os2\java16\openjdk6_b19_jre_os2_rc-20110221\bin;

set Path=S:\odin\system32;s:\download\os2\java16\openjdk6_b19_jre_os2_rc-20110221\bin;%Path%

set CLASSPATH=

set SWING_HOME=

set JAVA_HOME=

comment:3 Changed 9 years ago by dmik

  • Severity set to low

First, the file dialog has nothing to do with the sound support. Second, it looks like your Odin installation is broken somehow. Make sure you have the latest WPI from the link in the downloads section installed.

Next, the Playback/Capture? is not supported at the moment (as it has never been supported by Odin, and even Innotek Java doesn't support it; and there are currently no plans to add this support). You should try the Juke app instead. T If you don't get any sound with it (and see an exception about impossibility to open a compatible stream) then try to remove LIBPATHSTRICT=T from your environment. It is known that sound may not work when it is set.

comment:4 Changed 9 years ago by dmik

Also note that this sound demo application is *very* outdated and doesn't match the current JDK (contains some bugs that prevent it from working correctly). See #67 for details.

comment:5 Changed 9 years ago by dmik

With LIBPATHSTRICT=T the sound will definitely not work in RC (in its respective Odin32 counterpart to be exact). See #76 for details. So please try everything with SET LIBPATHSTRICT=T removed for now.

comment:6 Changed 9 years ago by dmik

  • Resolution set to worksforme
  • Status changed from new to closed

The test jar works as expected here with RC2. Closing as there is no further feedback.

Note: See TracTickets for help on using tickets.