Opened 9 years ago

Closed 9 years ago

#77 closed defect (fixed)

Can still not start Java applications

Reported by: elygre Owned by:
Priority: blocker Milestone: RC2
Component: general Version: 1.6.0-b19 RC
Severity: low Keywords:
Cc:

Description

This is the same situation as described in Ticket #57.
I have installed the new versions of Java and Odin and have still to reboot eCS 5-10 times before Genj is started. Each time the CPU-meter shows 99.9 % utilization for about 1-2 minutes before displaying the error message SYS1808: The process has stopped. The software diagnostic code (exception code) is 0005.
The new thing now is that trying to install Jalbum gives the same result (#58).
If I manage to start Genj I can close it and restart it many times without rebooting, but eventually it that luck also ends.
Normally if Genj has started I can also start the installation of Jalbum. First it displays a graphical screen and asks for language. Then a progress bar start moving, but after a few sec. it stops - and that is it. The CPU-meter show no use of the CPU (0.3 %).

Change History (6)

comment:1 Changed 9 years ago by elygre

  • Milestone set to GA

comment:2 Changed 9 years ago by dmik

Re SYS1808. I bet you are hitting the same bug in the DosQuerySysState? API I hit here from time to time (this API is VERY-VERY-VERY bogus but it's the only way to get the information it provides). So far I haven't heard that any one else but me were seeing it. So now I have to look at it I have collected some data to debug on.

In two words, what happens is that the list of process modules is broken and contains short circuits. As a result, the routine that walks it recursively never ends, eventually eats up all the stack and crashes.

comment:3 Changed 9 years ago by dmik

  • Severity set to low

comment:4 Changed 9 years ago by dmik

Ticket 31 is fixed. The hang should go away now. The test version of Odin is available at ftp://ftp.dmik.org/tmp/elygre/o_nohang.wpi. Please try to install it and report the results. Please note that this version is *not* for distribution.

comment:5 Changed 9 years ago by elygre

I have now installed the new version of Odin and, YES, the hang is gone. I have rebooted 5 times and every time Genj starts as hoped. Thank you.
I still can't install Jalbum, there is no change. The behavior is as described. I will create a new ticket after having downloaded Jalbum again and done some testing with the same jar-file in windows.

comment:6 Changed 9 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for testing.

Regarding the JAlbum installer hang. Please see #80.

Note: See TracTickets for help on using tickets.