Opened 6 years ago

Closed 6 years ago

#203 closed defect (fixed)

Open file dialog in AWT doesn't work.

Reported by: dmik Owned by:
Priority: major Milestone: GA5
Component: general Version: 1.6.0 Build 27 GA4
Severity: medium Keywords:
Cc:

Description

If an AWT program shows this dialog, it can't be dismissed and directory navigation doesn't actually work. The details and an example are here: http://svn.netlabs.org/odin32/ticket/93.

Change History (5)

comment:1 Changed 6 years ago by dmik

It turned out that the problem was due to the fact that Java subclassed the dialog procedure but it didn't call the previous procedure (it instead called DefWindowProc? which is generally not the same). I fixed it in r413.

Note that on real Windows it works because it uses the SetWindowSubclass? API (not implemented in Odin) which doesn't need to track the old windows procedure manually.

Anyway, it now should work. Joop, could you please test it? Basically you should replace JAWTOS2.DLL with the one from here: ftp://ftp.netlabs.org/pub/java/test/jawtos2.zip. This also contains a fix for #199.

comment:2 Changed 6 years ago by dmik

  • Milestone changed from Enhanced to GA5

comment:3 Changed 6 years ago by David McKenna

I'm not Joop, but I can confirm that at least ImageJ now shows its menus and the File Open... dialogs work with this test jawtos2.dll. Thanks!

comment:4 Changed 6 years ago by David McKenna

It also seems to fix the missing menus in LVMGUI (#164).

comment:5 Changed 6 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Great, I'm closing this and #164 then. Thanks for testing!

Note: See TracTickets for help on using tickets.