Opened 8 years ago

Closed 7 years ago

#164 closed defect (fixed)

Problem in LVMGUI with openjdk.b24GA2

Reported by: Anchieri Owned by:
Priority: minor Milestone: GA5
Component: general Version: 1.6.0-b24 GA2
Severity: low Keywords:
Cc:

Description

After installing your last GA2 version of OpenJdk? I have tested LVMGUI.
The program function almost fine, but the bar menu is not drew (is lack name of menu item).
Pointing the mouse over a menu item is possible to view its own Pull Down Menu and use it.
I attach a jpg file with the view of LVMGUI window without the bar menu.

Attachments (3)

LVMGUI-01.jpg (65.8 KB) - added by Anchieri 8 years ago.
lvmgui.cmd (584 bytes) - added by Anchieri 7 years ago.
hs_err_pid87.log (22.1 KB) - added by Anchieri 7 years ago.

Download all attachments as: .zip

Change History (14)

Changed 8 years ago by Anchieri

comment:1 Changed 8 years ago by abwillis

I can confirm that the same occurs here.

comment:2 Changed 8 years ago by diver

  • Milestone changed from Enhanced to GA3

comment:3 Changed 8 years ago by dmik

I can confirm that. Though it is not related to http://svn.netlabs.org/odin32/ticket/81 since with that one fixed the problem still persists.

Also, there are some other problems. In particular, clicking the right mouse button over a partition box throws a non-fatal exception (instead of showing the context menu):

Exception in thread "AWT-EventQueue-0" java.lang.IllegalArgumentException: origin not in parent's hierarchy
        at java.awt.PopupMenu.show(PopupMenu.java:165)
        at GUI$DrawDrives.processMouseEvent(lvmgui.java)
        at java.awt.Component.processEvent(Component.java:5901)
        at java.awt.Component.dispatchEventImpl(Component.java:4497)
        at java.awt.Component.dispatchEvent(Component.java:4323)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:649)
        at java.awt.EventQueue.access$000(EventQueue.java:96)
        at java.awt.EventQueue$1.run(EventQueue.java:608)
        at java.awt.EventQueue$1.run(EventQueue.java:606)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
        at java.awt.EventQueue$2.run(EventQueue.java:622)
        at java.awt.EventQueue$2.run(EventQueue.java:620)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:619)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

This suggests that something has changed in the Java runtime in an incompatible way. LVMGUI is VERY old (written for IBM Java 1.1) so I wouldn't be surprised if it uses something completely deprecated in OpenJDK 6. Unfortunately, since we don't have LVMGUI sources, we might not be able to fix this.

In either case, LVMGUI is so badly written that I don't think it makes a lot of sense to invest too much time in it; it may be easier to write an alternative from scratch (and there is some PM alternative in the work AFAIR).

But I will check the main menu issue anyway though. This may be the Odin problem (that appears only in AWT which is used by LVMGUI).

Last edited 8 years ago by dmik (previous) (diff)

comment:4 Changed 8 years ago by abwillis

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 8 years ago by abwillis

Actually... I realized that when I did the pull for the above it also pulled:
http://svn.netlabs.org/odin32/changeset/21998
so it could have been what resolved it.

comment:6 Changed 8 years ago by dmik

Hmm, are you sure? I can't see any changes here.

Can you revert 21998 and see if it comes back?

Last edited 8 years ago by dmik (previous) (diff)

comment:7 Changed 8 years ago by abwillis

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hmm, earlier I had launched it and seen the File menu missing, I then did the svn pull and build and copied the files over and then launched it again and had the file menu. I had thought I only had the one prompt open but apparently had another which was apparebntly pulling another java because it indeed is not working now.

comment:8 Changed 7 years ago by diver

  • Milestone changed from GA3 to Enhanced

comment:9 Changed 7 years ago by Anchieri

I have retested LVM with recently version b25GA3 but if start it without the CLASSPATH of JAVA11 THE PROGRAM don't start or close immediately, to test I have created one lvmgui.cmd that I attach to this bug report and the hs_err_pid87.log and here the output on pm window:

# A fatal error has been detected by the Java Runtime Environment:
#
# EXECPTION_ACCESS_VIOLATION (0x0000005) at pc=0x03dad10c, pid=87, tid=5701645

# JRE version: 6.0_25
# Java VM: OpenJDK Client VM (20.0-b12 mixed mode os2-x86 )
# Prblematic frame:
# C 0x03dad10c
#
# An error report file with mor information is saved as:
# C:\OS2\JAVAAPPS\hs_err_pid87.log
#

Changed 7 years ago by Anchieri

Changed 7 years ago by Anchieri

comment:10 Changed 7 years ago by dmik

From the report (execution of code on stack) smells like #161 again.

comment:11 Changed 7 years ago by dmik

  • Milestone changed from Enhanced to GA5
  • Resolution set to fixed
  • Status changed from reopened to closed

As mentioned in #203, fixing that defect fixes the original issue of this ticket (the menu) too, I've just checked this. There fore I'm closing this defect. Any other issues should be reported separately.

Note: See TracTickets for help on using tickets.