Opened 7 years ago

Closed 5 years ago

#174 closed defect (invalid)

FREEMIND crash

Reported by: warpwe Owned by:
Priority: major Milestone: Next
Component: general Version: 1.6.0 Build 25 GA3
Severity: medium Keywords:
Cc:

Description


Attachments (6)

FREEMIND.LOG (2.5 KB) - added by warpwe 7 years ago.
hs_err_pid169.log (1.7 KB) - added by warpwe 7 years ago.
hs_err_pid122.log (7.0 KB) - added by martini 7 years ago.
FREEMIND.2.LOG (2.4 KB) - added by warpwe 7 years ago.
hs_err_pid96.log (1.7 KB) - added by warpwe 7 years ago.
Crash_with_J4_fix.zip (31.1 KB) - added by warpwe 7 years ago.

Download all attachments as: .zip

Change History (19)

Changed 7 years ago by warpwe

Changed 7 years ago by warpwe

comment:1 Changed 7 years ago by dmik

  • Milestone changed from Enhanced to GA4

Okay, I can confirm the crashes in FreeMind? 0.9.0. Looks like one more SEH regression, as in #161.

comment:2 Changed 7 years ago by martini

I can confirm it does not work too.

I'm attaching the error log.

Changed 7 years ago by martini

comment:3 Changed 7 years ago by dmik

Please try this DLL ftp://ftp.netlabs.org/pub/odin/test/j4.zip (replace the one in the /bin/client dir) and report if it works now. Here it works with this DLL.

Changed 7 years ago by warpwe

Changed 7 years ago by warpwe

comment:4 Changed 7 years ago by warpwe

Hi,

thanks for your support.
I worked a while with freemind and then again a new crash.
New logfiles are attached.

MfG
Wilfried

comment:5 Changed 7 years ago by warpwe

Hi,

if I start FREEMIND with "JAVA -verbose" to catch additional information, no crash appears.

MfG
Wilfried

comment:6 Changed 7 years ago by dmik

This is the same as #133, comment 31.

comment:7 Changed 7 years ago by martini

Hi

FreeMind? works now with the j4 patch (ftp://ftp.netlabs.org/pub/odin/test/j4.zip) for me.

I'm running it using the .bat file.

java -Xmx256M -Xss8M -cp lib\freemind.jar;lib\commons-lang-2.0.jar;lib\forms-1.0.5.jar;lib\jibx\jibx-run.jar;lib\jibx\xpp3.jar;lib\bindings.jar freemind.main.FreeMindStarter?

Regards

Changed 7 years ago by warpwe

comment:8 Changed 7 years ago by warpwe

Hi,

now I have a freemind crash with -verbose switch on. Uploaded in Crash_with_J4_fix.zip
Please don't get confused with the pathname of java.

MfG
Wilfried

Last edited 7 years ago by warpwe (previous) (diff)

comment:9 Changed 7 years ago by dmik

This is the same as #133.

comment:10 Changed 7 years ago by Joop

java -Xmx256M -Xss8M -cp lib\freemind.jar;lib\commons-lang-2.0.jar;lib\forms-1.0.5.jar;lib\jibx\jibx-run.jar;lib\jibx\xpp3.jar;lib\bindings.jar freemind.main.FreeMindStarter??

Its not enough. Try this cmd file
@echo off
set BEGINLIBPATH=[drive: \JAVA]\JAVA160\bin
set path=[drive: Java]\JAVA160\bin
set CLASSPATH=
[Drive: freemind]
cd [Drive: freemind]\freemind
java -Xmx512M -Duser.home=[Drive: freemind]\freemind -cp lib\freemind.jar;lib\commons-lang-2.0.jar;lib\forms-1.0.5.jar;lib\jibx\jibx-run.jar;lib\jibx\xpp3.jar;lib\bindings.jar freemind.main.FreeMindStarter? 2>freemindbugs.txt

You have to replace [Drive: Java] and [Drive: freemind] with a real driveletter, further the paths could be different, adjust to your needs.

The "?" has to go, it crashes with me too with this. The 2 in 2>freemindbugs.txt is not a typo, you get nice logs with this if something goes wrong. I see in the example that a "?" is placed at the end "FreeMindStarter?", this is not in the original but something of this system here.

With above command file I can start up, search help etc. Its starting in my language, which is Dutch, full screen. The freemindbugs.txt only have this;
STDOUT: User patterns file I:\PROGRAMS\freemind\.freemind\patterns.xml not found.
STDOUT: User patterns file I:\PROGRAMS\freemind\.freemind\patterns.xml not found.

But that's not import and can certainly not crash the program. I didn't had used all the bells and whistles in the package, its a huge program. So if you find something please give exact key sequences and what menu item gives problems. I'm running Freemind 0.90 on an eCS 1.2NL with Java Version 1.6.0 Build 22 GA. Latest Java versions do have issues with menus in some packages like ImageJ.
You could also try Freeplane, which is some kind of successor of Freemind and where thing are developed a little faster if version numbers do say something. Use same cmd file with of course some changes in names.

comment:11 Changed 7 years ago by Joop

I could reproduce the crash, but this is a Java problem, not a Freemind problem. If you load programs AFTER that you have started Freemind than it will crash as soon as it needs more memory. If you load Freemind (or every other Java program) as last program than there are no problems. In the first I could not make 4 knots in Freemind and it did crash hard. In second way I could make many knots, sub knots and so on without a problem, saved the file and closed normally. The bugtracker only have the remarks as before. No hs_err_pidXX.log file. Also "-Xss8M" is as far as I know not possible in OS/2-eCS. I did run Freemind 0.90 with the commandfile setup as shown above.

comment:12 Changed 5 years ago by warpwe

Today I found the reson for the reported freemind crash.
The reason was a mixup of different versions of java-code in my startup script.
After using same bin-Path in JAVA_HOME, CLASSPATH, BeginLibPath? and PATH Freemind is stable here.

It's my fault, sorry.

comment:13 Changed 5 years ago by dmik

  • Resolution set to invalid
  • Status changed from new to closed

Good to hear that. I'm closing this then. Thanks for reporting.

Note: See TracTickets for help on using tickets.