Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#173 closed defect (fixed)

Fatal error launching JavaRDP; intermittent network connection

Reported by: lewisr Owned by:
Priority: major Milestone: GA4
Component: general Version: 1.6.0 Build 25 GA3
Severity: medium Keywords: launch rdp crash
Cc:

Description

Updated Odin to 0.8.5. :-)

All other Java apps seem to work (launch, at least) with this build, however, when starting JavaRDP (which works under b24 GA2), I get either a connection exception or a complete crash:

1080 [main] INFO com.elusiva.rdp - Connection successful
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0xc3d5b202, pid=207, tid=135659
65
#
# JRE version: 6.0_25
# Java VM: OpenJDK Client VM (20.0-b12 mixed mode os2-x86 )
# Problematic frame:
# C 0xc3d5b202
#
# An error report file with more information is saved as:
# C:\Java_Apps\JavaRDP\hs_err_pid207.log

The first launch brings about the connection exception. If I then re-launch within a few seconds, I get a successful startup, then the crash just as the window is about to be built (the frame flashes on the screen).

Attachments (1)

hs_err_pid207.log (1.3 KB) - added by lewisr 7 years ago.
Crash log from JavaRDP

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by lewisr

Crash log from JavaRDP

comment:1 Changed 7 years ago by dmik

Thanks for the report. I will check that. If it works with GA2 then it must be the same regression after changing the SEH scheme as in #161.

comment:2 Changed 7 years ago by dmik

There are several Java RDP projects, what exactly did you try? And what version? Better if you give me the exact link.

comment:3 Changed 7 years ago by Lewisr

I uploaded my particular package of JavaRDP to Hobbes, so you can pull it from there. It's 14.1.2, based on Lixia.

Thanks!

comment:4 Changed 7 years ago by Lewisr

Startup command example:

java -jar JavaRDP14-1.2.jar -g 1400x980 {servername or IP}

comment:5 Changed 7 years ago by dmik

  • Milestone changed from Enhanced to GA4

comment:6 Changed 7 years ago by abwillis

I had recommended this javardp package on OS2World and the same report was made about crashing:
http://www.os2world.com/component/option,com_smf/Itemid,63/topic,514.msg25859/topicseen,1/#new

comment:7 Changed 7 years ago by dmik

Again, does it work with GA2 for you?

comment:8 Changed 7 years ago by lewisr

properJavaRDP works for me under both GA2 and GA3, using the following .cmd file:

/* Simple jre application launcher */
parse source . . thiscmd

jbin = 'c:\Java160\bin\java.exe'
classpath = ''

/* find out the directory of this command file */  
rdpbin = filespec('drive', thiscmd)||filespec('path', thiscmd)  

/* run the application */ 
'@' || jbin' -cp 'rdpbin'properJavaRDP-1.1.jar;'rdpbin'log4j-java1.1.jar;'rdpbin'java-getopt-1.0.11.jar;'rdpbin'properJavaRDP14-1.1.jar net.propero.rdp.Rdesktop %1 %2 %3 %4 %5 %6 %7 %8 %9'

/* return any result to the caller */  
return rc

Screen drawing is noticeably slower than with Lixia, and maximizing the screen (or minimizing & restoring) practically hangs the guest CPU. However, it does not stall at startup as Lixia does under GA3. Note that for Lixia, I do not use any classpath during startup (I'll test that, though, but I'll need to pick apart the jar again to see what components are where).

comment:9 Changed 7 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Could you try it with the hot fix please? (ftp://ftp.netlabs.org/pub/java/openjdk6_b25_ga3/hotfix_ga3_1-20120807.zip). It should work now. Feel free to re-open if not.

comment:10 Changed 7 years ago by lewisr

Bravo!

Confirmed fixed (for me, at least).

Thanks!!!!

comment:11 Changed 7 years ago by warpuser

Works here as well with the version from hobbes.

Note: See TracTickets for help on using tickets.