Opened 9 years ago

Closed 8 years ago

#112 closed defect (fixed)

SmartGIT issues

Reported by: dmik Owned by:
Priority: major Milestone: GA2
Component: general Version: 1.6.0-b22 WSE
Severity: medium Keywords:
Cc:

Description

SmartGIT 2.0.4 cannot recognize the contents of the local repository. For a newly created one (git init) it will show the "unknown" status.

For an existing repository it will list its files but almost all will be shown as 'modified' while there are actually no modifications at all.

Change History (7)

comment:1 Changed 9 years ago by dmik

  • Milestone changed from GA to Enhanced

I played with SmartGIT a bit more. I also tried to use the Linux version of SmartGIT to access the repositories on the OS/2 machine (through Samba) and it showed exactly the same behavior as described above. This makes me think that the problem is in SmartGIT itself, not in Odin: looks like they treat the OS/2 platform as Linux and hence a bunch of the permission and path problems.

So we should probably contact the developers of SmartGIT and ask them to fix it (no confidence that they will do it though -- it's a commercial product).

I will leave this defect open to track the issue but will move it out of the GA milestone.

comment:2 Changed 8 years ago by dmik

  • Milestone changed from Enhanced to GA2

The syntevo people turned out to be quite responsive. I created this report: http://smartgit.3668570.n2.nabble.com/Add-OS-2-support-tp6599276p6599276.html and got a (private) reply that gives us a hint where the problem is. I created #139 for that.

comment:3 Changed 8 years ago by dmik

#139 is fixed and many commands now work in SmartGit?, great. Will contact syntevo again.

comment:4 Changed 8 years ago by dmik

Added support for CREATE_UNICODE_ENVIRONMENT in Odin (r 21673). The absence of this flag caused some weird behavior in SmartGit? (http://smartgit.3668570.n2.nabble.com/git-version-fails-if-smartgit-core-execitable-log-level-is-DEBUG-tp6599300p6599300.html) because the environment of the git process was screwed up.

comment:5 Changed 8 years ago by dmik

Yet another problem in Odin has just been fixed (r 21674) that in turn fixes the SmartGit? behavior: the Log (Ctrl-H) command didn't work on repository roots (the most common case BTW), now it does. Great.

comment:6 Changed 8 years ago by dmik

  • Summary changed from SmartGIT doesn't recognize local repositories to SmartGIT issues

All the original problems with SmartGIT described above have been fixed it seems. There are however a few other problems:

  1. SmartGIT 2.1 doesn't want to recognize git.exe any longer. Seems that git.exe --version doesn't return any output to git or SmartGIT can't parse it. I will test.
  1. SmartGIT 3 and above doesn't start at all because it says that OS/2 is not supported. Great. I will have to contact the developers to see what can be done here.

comment:7 Changed 8 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Hmm, it seems that problem 1 was actually a SmartGIT 2.1 bug. Upgrading it to 2.1.7 solves the issue, it seems to work flawlessly. They even seem to have fixed the permission problems on Windows-like platforms, so that there is no need to set filemode = false in .git/config. Great!

Regarding the second issue, I created a new ticket #158 as it's not actually related to this one (which is considered as done now).

Note: See TracTickets for help on using tickets.