Opened 7 years ago

Last modified 5 years ago

#158 new task

SmartGIT 3 doesn't support OS/2

Reported by: dmik Owned by:
Priority: Feedback Pending Milestone: Next
Component: general Version: 1.6.0-b22 GA
Severity: medium Keywords:
Cc: ggamba@…, dryeo

Description

An attempt to start SmartGIT 3 (which has the RC 4 state ATM) ends up with this:

Not (yet) supported operating system OS/2

We have to contact the developers to resolve this issue.

Change History (13)

comment:1 Changed 7 years ago by dmik

Given that it is not released yet, and that SmartGIT 2.1.7 works quite well, this task isn't very high priority.

comment:2 Changed 7 years ago by ggamba

  • Cc ggamba@… added

comment:3 Changed 7 years ago by ggamba

No luck with SmartSVN 7.1 too, but the error message is different:

[C:\Scrivania]C:\PROGRAMS\openjdk6\bin\java.exe -jar C:\PROGRAMS\SmartCVS7\lib\smartcvs.jar

An incompatible Java version has been detected which has been reported to cause strange bugs. Aborting now.

Added a new ticket here: http://trac.netlabs.org/java/ticket/168

Last edited 7 years ago by ggamba (previous) (diff)

comment:4 Changed 6 years ago by diver

  • Priority changed from major to Feedback Pending

Gabriele are you eventually willing to contact the developers with the SmartGit?, SmartSVN and SmartCVS problems?

comment:5 Changed 6 years ago by ggamba

I never used SmartGit? or SmartSVN. I'll report about SmartCVS, despite thinking that should be the OpenJDK developers complaining about the "An incompatible Java version has been detected" :-)

comment:6 Changed 6 years ago by dmik

Well you are not fully correct here. SmartCVS people decided that they dont want to support openjdk because they had many problems with it due to diffrences from th official sun build. Now the situation has changed a lot and it should be smartcvs end-users who asks the devs to fix it because a lot use openjdk now.

comment:7 follow-up: Changed 6 years ago by ggamba

I wrote to Syntevo support asking for smartcvs.checkIncompatibleJava=false for SmartCVS and letting them know that SmartSVN works ok with OpenJDK.

I did not mention SmartGIT, as I never tried it.

comment:8 in reply to: ↑ 7 Changed 6 years ago by ggamba

Replying to ggamba:

I wrote to Syntevo support asking for smartcvs.checkIncompatibleJava=false for SmartCVS and letting them know that SmartSVN works ok with OpenJDK.

I did not mention SmartGIT, as I never tried it.

Current SmartCVS generic bundle doesn't check the Java version any more :-)
Thomas from Syntevo was very supportive and released the new package in a few days. From this experience, I can only suggest others having problems with SmartGIT or or SmartSVN to contact him!

comment:9 Changed 6 years ago by diver

i wonder if newer SmartGit? and SmartSVN now also work, as SmartCVS does now.
Gabriele could you eventually also try them?

comment:10 Changed 6 years ago by dryeo

I just tested the newly released SmartGit? 3.0.10, same error "Not (yet) supported operating system OS/2"

comment:11 Changed 6 years ago by dryeo

  • Cc dryeo added

comment:12 Changed 6 years ago by diver

dave doesn't smartgit.checkIncompatibleJava=false not work here?

comment:13 Changed 5 years ago by Lewisr

The "Not (yet) supported operating system OS/2" apparently stems from lack of SWT support. I am getting this with SmartSVN 8, and opened a ticket with WANdisco. See my notes in ticket #72 which include Liam McLennan?'s response to my ticket over there.

Lewis

Note: See TracTickets for help on using tickets.