Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#113 closed defect (wontfix)

Problem running JAlbum 9.4.1

Reported by: Peter_OS2 Owned by: Peter
Priority: major Milestone: GA
Component: general Version: 1.6.0-b22 WSE
Severity: medium Keywords: JAlbum 9.4.1
Cc:

Description

Jalbum 9.4.1 will not start. It creates no LOG. The version 9.3 works without problems.

Change History (5)

comment:1 follow-up: Changed 4 years ago by Joop

I tried this version with Java 1.5001 and Java 1.6 end both end with this;

Error: null
java.lang.reflect.InvocationTargetException?

at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.

java:57)

at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAcces?

sorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:616)
at se.datadosen.jalbum.Main.main(Main.java:28)

Caused by: java.lang.NullPointerException?

at se.datadosen.jalbum.Config.getConfigFile(Config.java:154)
at se.datadosen.jalbum.JAlbum.main(JAlbum.java:124)
... 5 more

Seems to be a problem within JAlbum and not within Java. I will inform JAlbum bugtracker.

comment:2 Changed 4 years ago by Joop

Bug reported at 04-Jun-2011 15:20 in JAlbum Bug Reports.

comment:3 in reply to: ↑ 1 Changed 4 years ago by Peter_OS2

Replying to Joop:

I tried this version with Java 1.5001 and Java 1.6 end both end with this;

I treid it with Java 1.5.0_07 (running with AR5OS2.EXE) and it works.

comment:4 follow-up: Changed 4 years ago by dmik

  • Milestone set to GA
  • Resolution set to wontfix
  • Severity changed from highest to medium
  • Status changed from new to closed

Thank you for the report, Peter_OS2.

I got the very same problem with version 9.4.1.

Peter_OS2, Java 1.5.0_07 gives exactly the same error here too.

Judging from the exception (java.lang.NullPointerException? at se.datadosen.jalbum.Config.getConfigFile(Config.java:154)) this may mean that it wants some configuration file but cannot find it and simply lets the exception terminate the application instead of properly handling it.

The information at http://jalbum.net/forum/thread.jspa?threadID=39062 lets me think that jAlbum expects a certain directory layout on an eCS machine where jAlbum runs (it obviously misdetects it either as Windows or as Linux) and can't cope with a failure to find this layout. To me, it's clearly a jAlbum bug.

Next, (Joop, you can pass it on to the developer in the above forum thread, thank you):


The suggested workaround with using -Dappdata=D:\some_valid_path works well here with version 9.4.1.

However, if you download http://jalbum.net/download/jalbum-core.jar (which is currently version 9.4.4 BTW), it behaves kind of weird: when no -Dappdata option is used at all, it still throws the same NullPointerException? in the same file, but this time line 155 instead of 154).

When you specify -Dappdata, it works but it seems to totally ignore this argument. You can write whatever you want there (e.g. -Dappdata=trololo), it doesn't seem to have any effect and I couldn't find any jalbum settings files anywhere so they are created at some hidden location where I couldn't easily spot them or not created at all.


Anyway since it's not an OpenJDK bug, I'm closing this.

comment:5 in reply to: ↑ 4 Changed 3 years ago by Joop

Replying to dmik:

Thank you for the report, Peter_OS2.

I got the very same problem with version 9.4.1.

Peter_OS2, Java 1.5.0_07 gives exactly the same error here too.

Judging from the exception (java.lang.NullPointerException? at se.datadosen.jalbum.Config.getConfigFile(Config.java:154)) this may mean that it wants some configuration file but cannot find it and simply lets the exception terminate the application instead of properly handling it.

The information at http://jalbum.net/forum/thread.jspa?threadID=39062 lets me think that jAlbum expects a certain directory layout on an eCS machine where jAlbum runs (it obviously misdetects it either as Windows or as Linux) and can't cope with a failure to find this layout. To me, it's clearly a jAlbum bug.

Next, (Joop, you can pass it on to the developer in the above forum thread, thank you):


The suggested workaround with using -Dappdata=D:\some_valid_path works well here with version 9.4.1.

However, if you download http://jalbum.net/download/jalbum-core.jar (which is currently version 9.4.4 BTW), it behaves kind of weird: when no -Dappdata option is used at all, it still throws the same NullPointerException? in the same file, but this time line 155 instead of 154).

When you specify -Dappdata, it works but it seems to totally ignore this argument. You can write whatever you want there (e.g. -Dappdata=trololo), it doesn't seem to have any effect and I couldn't find any jalbum settings files anywhere so they are created at some hidden location where I couldn't easily spot them or not created at all.


Anyway since it's not an OpenJDK bug, I'm closing this.

The -D argument have to be given before the -jar argument. I use this in a cmd file and it works up to 9.5;
set appdata=[drive:]\[directory]\MyAlbums?. The latter part in the "set appdata" is made by JAlbum somewhere on your drive. If you take that for your appdata it will create a new directory in it with the settings file. Now all is in one directory from JAlbum.

Note: See TracTickets for help on using tickets.