#56 closed defect (fixed)

FAT32 partition : file contents vanish

Reported by: landb Owned by:
Priority: major Milestone: Future
Component: IFS Version:
Severity: medium Keywords:
Cc:

Description

This ticket is included for completness

IN #45 lewisr refers to "a user of Arcaos" having a problem and leaving it to him to report. I am that user and I did not report it because lewisr said it was fixed in v249.

I installed the then layest version and have indeed not seen the "vanishing contents problem" but instead hit problem #46


When obeying some CMD files instead of the CMD being obeyed the content of the file is cleared instead.

So far as I can see this only affects files on a FAT32 formatted partition.

It does not happen for all files but for those it does it is 100% consistent.

This is not an effect I have ever seen before and I wonder if it could possibly be a FAT32 bug. Steps To Reproduce (on my system!) Boot ARCAOS 5.0

Open an OS2 command window type "ex" (not quotes)

The ex.cmd contains just exit so this should cause the window to exit. Instead it returns to the prompt, and looking at the file (type cmd\ex.cmd) shows the contents have gone.

Change History (2)

comment:1 Changed 13 months ago by landb

Since I believe this is a fixed problem the ticket can be closed

comment:2 Changed 13 months ago by diver

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r249 and closing as requested by the user

Note: See TracTickets for help on using tickets.