Opened 2 years ago

Closed 19 months ago

#45 closed enhancement (worksforme)

Need IFS version without exFAT

Reported by: lewisr Owned by:
Priority: major Milestone: Future
Component: IFS Version:
Severity: high Keywords:
Cc:

Description

exFAT is proprietary Microsoft technology, regardless what code Samsung wrongfully put out with a GPL license attached to it (it wasn't their code to so license).

Accordingly, Arca Noae cannot distribute any driver with exFAT code in it. Rightfully, exFAT belongs in a separate IFS, but I'm not going to make that argument, here. Instead, I would request a separate build of FAT32.IFS without exFAT support.

The build of FAT32 included in ArcaOS apparently contains some issues which have subsequently been addressed, and we would like to provide an updated package, however, we are currently only able to refer users here to obtain code from the project page.

Change History (10)

comment:1 Changed 2 years ago by valerius

Is it not better to not include fat32.ifs in ArcaOS at all then? I doubt that users need "castrated" version. Castrated QSINIT, fat32, XWP, ... Is this not too much? Why do we need to include it to the distribution if user will need to install a full version anyway? Samsung code is Linux, not OS/2, so it has nothing to do with fat32.ifs. exFAT support in fat32.ifs is written from scratch. exFAT is not a separate IFS, because it is FAT too. Why create yet another FAT driver from scratch if I could enhance an existing one? It will require significantly less efforts because it uses much of existing routines. Ok, I'll think about adding #ifdef's to switch the exFAT support off (Not sure if it is really needed, though, because exFAT support is switched off by default, if /exfat is not specified on the command line).

Last edited 2 years ago by valerius (previous) (diff)

comment:2 Changed 2 years ago by valerius

I'd say that FAT is proprietary the same way exFAT is. Linux developers were required to use special tricks to bypass the VFAT LFN patent in their FAT driver, for example. We don't do that only because M$ does not pay attention to OS/2. So it is not good thing to use FAT in our OS at all, not exFAT only.

Last edited 2 years ago by valerius (previous) (diff)

comment:3 Changed 2 years ago by valerius

If fat32.ifs contains issues, why I don't see tickets here creeated? I don't have any access to ArcaNoae? bug trackers, so I would expect issues created here. At least, I did not saw any feedback here these several months from people other than Lars Erdmann and Andy Willis.

comment:4 Changed 2 years ago by valerius

Hm, interesting, did Jan van Wijk payed M$ to use exFAT in dfsee? As I see that new version of it, 14.4 contains some exFAT support, and nobody says that it is proprietary technology...

PS: ah, it is called EFAT here... Maybe, I could rename it the same way, and formally, I will be not using exFAT?

PPS: In my country patenting ideas and algorithms is not allowed

Last edited 2 years ago by valerius (previous) (diff)

comment:5 Changed 2 years ago by lewisr

DFSee is not an Arca Noae product. FSYS is not a US company, and has a lower risk of legal action taken by MS than Arca Naoe. As stated, as a matter of policy, Arca Noae will not include exFAT support in any of our products.

FAT16 support is provided by IBM, and as far as we know, was properly licensed from MS at the time of its inclusion in the OS. Thus, FAT16 is not our concern. Renaming the support to make it less of a target is not a viable solution for us. We need this code excluded - completely - from any code we ship. Period.

Your country: That's fine. Microsoft is a US company holding multiple US patents. Arca Noae is a US company subject to the laws of the US. Patents are what they are, and I don't begrudge Microsoft for making use of them to protect its investment in R&D. None of this may matter in your country, but is *all* matters in ours and to us.

Issues with FAT32: The issue which just came up was reported *yesterday*. See Arca Noae ticket https://mantis.arcanoae.com/view.php?id=1101. An earlier issue was reported during beta testing, but as none of the rest of us could reproduce, I left it to the tester to report here. I suppose he did not. As you know, I have been quite active in reporting my results with every version I have tested, as time has allowed.

Not including FAT32 vs "castration" comment: Do I really need to respond to this? ArcaOS provides no "castrated" versions of anything. FAT32 support is needed during install when a customer may need to copy log files and such, and expecting him to have a stick formatted as HPFS or completely empty and able to be formatted as HPFS or FAT16 is unrealistic. Please. I am making a legitimate request here not to infringe on Microsoft's patent. I should not need to explain further.

comment:6 Changed 2 years ago by valerius

Ok, I'll #ifdef the exFAT-related code. But are you sure that not specifying the /exfat switch is not sufficient? As exFAT support is disabled by default. (I understand that you don't want to be sued by M$, of course). Also please, direct all users reporting issues with fat32, here, as I don't read ArcaNoae? bug trackers. (And I cannot read your bugtracker without registration).

Regarding the "castrated" versions -- I know about XWP being supplied since eCS as eWP with some features deleted, like Sliding focus (which I'm using a lot), pages of WPProgramFile object settings notebook, about imports/exports/resources (very useful feature, in my opinion). I suspect that it is the same in ArcaOS, like it was in eCS. Also, I heard that ArcaOS is used "customized" version of QSINIT. I don't know, why the full version is not good enough. (I only heard of it, as I have no ArcaOS copy atm).

FAT16 support is provided by IBM, and as far as we know, was properly licensed from MS at the time of its inclusion in the OS. Thus, FAT16 is not our concern.

I doubt that FAT32 and VFAT is licensed by IBM, so I suspect that fat32/vfat is the same way patented as exFAT is. But I can agree that M$ exFAT patent can be used with more probability than the older ones.

Last edited 2 years ago by valerius (previous) (diff)

comment:7 Changed 2 years ago by abwillis

Unfortunately, not enabling the /exfat switch is insufficient to avoid patent infringement and thus the possibility of a lawsuit.

comment:8 Changed 2 years ago by valerius

2lewisr: Since r267, I added #ifdef EXFAT in all IFS/CHKDSK/FORMAT/etc code, so, now creating builds without exFAT support is possible. For that, you need to comment the !ifeq EXFAT 1 statement out, at the beginning of makefile.mk. The .WPI archive becomes 27 KB less :) Not so much code, indeed. Please test. (See archives with suffix "-noexfat" at the usual place ftp://osfree.org/upload/fat32/)

Last edited 2 years ago by valerius (previous) (diff)

comment:9 Changed 19 months ago by valerius

Ok, closing this ticket because of no feedback. I also see no thanks for creating a version without exFAT. And I see they're distributing it since ArcaOS 5.0.1, ok.

comment:10 Changed 19 months ago by valerius

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.