Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#534 closed defect (fixed)

ThinkCentre A57 does not power off with ACPI 3.19.14/15, needs additional tool to succeed

Reported by: herwigb Owned by: dazarewicz
Priority: major Milestone: Release 4.00
Component: ACPI PSD Version: 3.19.15
Keywords: Cc:

Description

This a ThinkCentre A57 with a Core2Duo. Power off used to work a year ago, but stopped with later revisions of pre-ACPI 3.19.02.

Power Off also does not work with ACPI 3.19.11/14/15.

I tried:

CONFIG.SYSCPUsResult
PSD=ACPI.PSD (no switch)2power off does not work
PSD=ACPI.PSD /VW2power off does not work
PSD=ACPI.PSD /MAXCPU=11power off works
PSD=ACPI.PSD /VW /MAXCPU=11power off works

I did some more testing and found out that in SMP mode (2 CPUs on) if I turn off the second CPU using CPU/2 utility from Roman Stangl before shutdown, the machine is properly powered down.

Note: Also power management does not work with this machine (will be a separate Ticket).

Change History (9)

comment:1 Changed 7 years ago by dazarewicz

What are you using to do a power off?

To test power off, open a command window and type: acpistat poweroff

If that works, then the PSD (and your ACPI for that matter) works properly and indicates that there is a problem with whatever mechanism you are using to power off.

For example, there is a known problem in the xworkplace (eShutdown) that will be fixed in the next release.

comment:2 Changed 7 years ago by herwigb

I used xShutdown from XWP 1.0.9 beta3 (the "next" release, Rich's build), however the behaviour using acpi\util\poweroff.exe is consistent: Does not power off with 2 cores enabled, powers off with only 1 core.

Output from acpistat poweroff (does not power off):

The version of ACPI.PSD that is installed is 3.19.14
The system is operating in Symmetric mode (Mode 2)
The kernel is 105 SMP

Number of IRQs available: 24
IRQ 00 count 6555
IRQ 01 count 848
IRQ 08 count 192071
IRQ 09 count 155
IRQ 14 count 19767
IRQ 16 count 469
IRQ 17 count 2200
IRQ 23 count 3694

========== CPU0 ==================
ACPI name [P001]
IPIGenCount = 15184      IPICount    = 32669     
IPIHLT      = 0          IdleCount   = 246899     BusyCount   = 21566     
C1Count     = 0          C2Count     = 0          C3Count     = 0         
========== CPU1 ==================
ACPI name [P002]
IPIGenCount = 32669      IPICount    = 15184     
IPIHLT      = 0          IdleCount   = 31955      BusyCount   = 31954     
C1Count     = 0          C2Count     = 0          C3Count     = 0         

The behaviour is 100% reproducible here.

comment:3 Changed 7 years ago by herwigb

I have a second ThinkCentre A57 with a Core2Quad here: Everything is the same as with the Core2Duo machine, however I have to turn off CPU cores 2, 3 and 4 before it is powered off properly (both with XWP 1.0.9 beta 3 and \acpi\util\poweroff.exe.

comment:4 Changed 7 years ago by dazarewicz

The version of acpistat you are using is old. Please use current software. Even 3.19.14 is out of date now. acpistat poweroff does not produce any output. It just powers the system off.

You have indicated version 3.19.15 in the ticket but obviously you are running older software than that. The acpistat command indicates that the PSD is version 3.19.14 and the acpistat command may even be older than that.

The version of xworkplace you have does NOT have the defect fixed. My fixes for xworkplace finally made it into the repository just this afternoon.

"poweroff.exe' is a sample from the toolkit and is only distributed as source with the toolkit. That source also had the same defect in it which is probably why that defect got propagated to practically every power off utility there is.

comment:5 follow-up: Changed 7 years ago by herwigb

ok. Updated ACPI to 3.19.15.

acpistat poweroff properly powers off the machine even with all cores enabled.

Note: Booting with this version does not work properly unless acpidaemon.exe is REMmed out in CONFIG.SYS. Seems like acpidaemon puts the machine into suspend mode (or similar) as soon as it is started.

comment:6 Changed 7 years ago by dazarewicz

ok. Updated ACPI to 3.19.15.

acpistat poweroff properly powers off the machine even with all cores enabled.

Ok good. We are still working on the fix for xworkplace.

Note: Booting with this version does not work properly unless acpidaemon.exe is REMmed out >in CONFIG.SYS. Seems like acpidaemon puts the machine into suspend mode (or similar) as >soon as it is started.

That problem exists in a few systems with misbehaving SLPB devices. See http://svn.netlabs.org/acpi/wiki/KnownProblems

comment:7 Changed 7 years ago by herwigb

Power off via xShutdown from Rich Walsh's xwp 1.0.9 preview still does not work for the machine...

comment:8 in reply to: ↑ 5 Changed 7 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from new to closed

Replying to herwigb:

ok. Updated ACPI to 3.19.15.

acpistat poweroff properly powers off the machine even with all cores enabled.

This proves that the power off issue is not an ACPI or PSD problem.

Note: Booting with this version does not work properly unless acpidaemon.exe is REMmed out in CONFIG.SYS. Seems like acpidaemon puts the machine into suspend mode (or similar) as soon as it is started.

A workaround for this problem was implemented in version 3.19.16 and higher.

Please read the Known Problems page http://svn.netlabs.org/acpi/wiki/KnownProblems for a description of the resolution of both of these issues.

Since there is no remaining ACPI / PSD issue in this ticket, it will be closed.

comment:9 Changed 7 years ago by herwigb

Just a note that supports your point of view: Andreas Buchinger created a fix for xwp shutdown, that closely follows the method of acpistat poweroff and it works perfectly here. However Andreas Buchinger has a hard time arguing with the maintainer of xwp, who claims the code is still faulty - eventually you could help Andreas Buchinger to get his code into xwp. thx for your efforts. They are appreciated.

Note: See TracTickets for help on using tickets.