Opened 8 years ago

Closed 7 years ago

#533 closed defect (unknown)

Poor performance, trap e and no power off on Intel 945C SBC

Reported by: BlondeGuy Owned by: dazarewicz
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.19.15
Keywords: Cc:

Description

I'm working with an single board computer in a passive backplane industrial computer. Intel 945C-based system. Works without ACPI, but does not power off. Works with ACPI 3.18, but does not power off and did not attempt /SMP. CPU is single core hyperthreading CPU.

ACPI 3.19.15 booted OK first time, but no power off. Second time, I got the situation (which every version of ACPI has always done occasionally on every machine I've ever tried.) with high CPU use. I didn't try this time, but CPUSPEED usually will show both CPU running at radically different speeds.

I tried to power off, and I got trap E. See attachment for register dump screen.

Attachments (1)

trapdump.jpg (71.6 KB) - added by BlondeGuy 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by BlondeGuy

comment:1 Changed 8 years ago by BlondeGuy

I tried CPUSPEED, but it shows twin 3400 CPU. So that isn't the case this time. And the trap happens each time I try to shut down.

comment:2 Changed 8 years ago by BlondeGuy

If I turn off hyperthreading, then I get no trap or high CPU usage, but power off still does not work.

comment:3 Changed 8 years ago by dazarewicz

Hyperthreading should not be enabled. There is a note about that in the readme and in the docs. It seems to work OK on some systems, and not on others. My guess is that it has something to do with how the computer vendor wrote the ACPI but I haven't spent any time looking into it.

What are you using to power off?

Open a command window and type: acpistat poweroff

If that works to power off your system, then there is nothing wrong with the PSD. Most, if not all power off utilities, including xworkplace have a defect that prevents them from working properly. Xworkplace is currently being updated with a fix.

comment:4 Changed 8 years ago by BlondeGuy

Hyperthreading is off.

If I run acpistat, with or without poweroff, I get this

(a bunch of IRQ and numbers)

SYS1808: The process has stopped. The software diagnostic code (exception code) is 0005.

comment:5 Changed 8 years ago by dazarewicz

It appears that you are using mismatched versions of the different modules, or at least an old version of acpistat.exe. Please only use matched versions of all the modules (ACPI.PSD, ACPI32.DLL, AcpiDaemon?.exe, APM.ADD, and acpistat.exe), and preferably the latest ones. Newer versions do some version checking to prevent mismatched version problems, but older versions did not do any version checking.

See also: http://svn.netlabs.org/acpi/wiki/KnownProblems

comment:6 Changed 8 years ago by BlondeGuy

Thanks for the reply. I found the new location for AcpiStat?.exe, and ran it. Now the system simply stops (mouse won't move) after running AcpiStat? poweroff. The fans continue to run and the system does not power off.

comment:7 Changed 7 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending

Have you tried "acpistat poweroff" with the current version?

comment:8 Changed 7 years ago by dazarewicz

  • Resolution set to unknown
  • Status changed from new to closed

No reply from Reporter. Power off is known to work properly.

Note: See TracTickets for help on using tickets.