Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#535 closed defect (Unrelated)

DOSBox fails to run after installing acpi 3.19.15

Reported by: losepete Owned by: dazarewicz
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.19.15
Keywords: Cc: acpi@…

Description

I installed acpi 3.19.15 to my eCS2.1 system and all seemded to be working fine - until I tried running some of my old DOS games in DOSBox.

DOSBox was working fine prior to installing acpi 3.19.15

Now DOSBox hangs/crashes immediately on starting.

To test that the problem is acpi I put REM at the front of the acpi line in the config.sys file - it is the only acpi related line in the config.sys as I do not use apm or acpidaemon - and rebooted.

Result: DOSBox works fine.

I then deleted the REM from the front of the config.sys line and rebooted.

Result: DOSBox hangs/crashes immediately on starting.

Mainboard/chipset involved: Asus M2N using nVidia nForce430/MCP61

Change History (7)

comment:1 Changed 7 years ago by losepete

Just to add some information: The last build of acpi that allows DOSBox to work seems to be 3.19.03

I have tried 3.19.10, 3.19.14 and 3.19.15 and all fail to let DOSBox run.

comment:2 Changed 7 years ago by yoda

  • Cc acpi@… added

Maybe it has problems with APIC and high IRQ's.

Try using /VW or /PIC with ACPI driver, and see if it changes anything.

comment:3 Changed 7 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending

dosbox has some debugging capability. It would be very helpful if you could enable the dosbox debugging and provide further information on what it thinks is not working.

comment:4 follow-up: Changed 7 years ago by losepete

The problem is resolved by using the /VW switch which prevents high IRQs

With regard to enabling dosbox debugging: If I could find some docs that tell me how to enable this I would. The only mention I can find in the dosbox package is this:-

dosbox*.exe: If you use the name of one of the different binary versions, it's built for you.

The names are dosbox.exe, dosboxd.exe, dosboxhd.exe being the non-debugging binaries without and with internal DOSBOX debugger support (dosboxd and dosboxhd). The debugging binaries add a suffix of "_d" to the filename, e.g. dosboxd_d.exe being the debugging version including the normal DOSBOX debugger.

However, there is no dosboxd.exe or dosboxhd.exe included in the dosbox package I have installed. I am using dosbox 0.74

comment:5 in reply to: ↑ 4 Changed 7 years ago by dazarewicz

Replying to losepete:

The problem is resolved by using the /VW switch which prevents high IRQs

This pretty much proves that dosbox has issues with high interrupts. This is not unexpected. Most DOS stuff doesn't work with "high" interrupts without some kind of workaround. This is not a ACPI.PSD defect.

With regard to enabling dosbox debugging: If I could find some docs that tell me how to enable this I would. The only mention I can find in the dosbox package is this:-

dosbox*.exe: If you use the name of one of the different binary versions, it's built for you.

The names are dosbox.exe, dosboxd.exe, dosboxhd.exe being the non-debugging binaries without and with internal DOSBOX debugger support (dosboxd and dosboxhd). The debugging binaries add a suffix of "_d" to the filename, e.g. dosboxd_d.exe being the debugging version including the normal DOSBOX debugger.

However, there is no dosboxd.exe or dosboxhd.exe included in the dosbox package I have installed. I am using dosbox 0.74

With the little time I spent looking at it I couldn't find a debug version and I don't really have the time to be debugging dosbox.

It appears that the issue being reported in this ticket is not a defect or problem with any of the ACPI project software, but rather a dosbox problem. Since this is the place for ACPI problems, not dosbox problems, this ticket should be closed.

comment:6 Changed 7 years ago by dazarewicz

  • Resolution set to Unrelated
  • Status changed from new to closed

This is a DosBox? problem not a PSD issue. Ticket closed -> Can't fix / unrelated.

comment:7 Changed 6 years ago by losepete

Just to update this report:

I have recently changed mainboard; previous mainboard was an Asus M2n using nForce430/MCP61 chipsets, new mainboard is an Asus M3A32-MVP using AMD790FX/SB600 chipsets.

With the M2N mainboard I could not run dosbox without using /VW on the config.sys acpi line.

With the M3A32-MVP mainboard I do not use the acpi /VW switch, high IRQs are active according to Hardware Manager and dosbox runs fine.

This suggests the problem was not with dosbox at all but some sort of interaction between acpi and the chipsets on the M2N mainboard.

Note: See TracTickets for help on using tickets.