Opened 8 years ago

Closed 7 years ago

#523 closed defect (fixed)

3.19.14 + Gateway 7405 Notebook

Reported by: David McKenna Owned by: dazarewicz
Priority: major Milestone: Release 4.00
Component: ACPI PSD Version: 3.21.04
Keywords: Cc:

Description

This combo will only boot with ACPI.PSD /PIC (eCS 2.1). Once booted, USB and Wireless don't work, and the desktop startup sound keeps repeating. I installed the debug version and captured logs.

This notebook works well in /APIC mode with 3.18. It will only work in /PIC mode if I add:

LINK LNKA 9

LINK LNKB 11

LINK LNKC 11

LINK LNKD 9

to ACPI.CFG.

3.19.03 also works with this ACPI.CFG file (no /APIC mode available with that).

Attachments (4)

LAPMACHINE-20111231-acpi-3.19.14.zip (28.2 KB) - added by David McKenna 8 years ago.
logs for Gateway 7405 laptop
debug 3.20.01 OV.JPG (232.2 KB) - added by David McKenna 8 years ago.
Screen at hang using debug kernel
acpi.log (8.2 KB) - added by David McKenna 7 years ago.
ACPICA$ from 3.21.04
LAPMACHINE-20121216-acpi-3.21.04.zip (55.2 KB) - added by David McKenna 7 years ago.
Testlog for booting 3.21.04 in APIC mode

Download all attachments as: .zip

Change History (37)

Changed 8 years ago by David McKenna

logs for Gateway 7405 laptop

comment:1 Changed 8 years ago by dazarewicz

  • Owner changed from eco to dazarewicz
  • Status changed from new to assigned

Thanks for the log.

The issue you are having is next on my list to work on.

I'm surprised that system doesn't work with /VW.

comment:2 Changed 8 years ago by David McKenna

With no switches and with the /VW switch, <alt>-F2 would reveal boot hanging with RESOURCE.SYS on the logo screen.

comment:3 Changed 8 years ago by dazarewicz

Ok, after further investigation, your problem is different than I originally thought. It is on my list to work on. Thanks for testing.

comment:4 Changed 8 years ago by dazarewicz

Does this machine have a serial port by any chance?

If yes, can you capture a serial port log with "PSD=ACPI.PSD /DBGLVL=3 /O1" (for serial port 1) and attach it to this ticket? See the readme under "Reporting Problems" for more details.

If no, please let me know.

comment:5 Changed 8 years ago by David McKenna

Unfortunately, no - there are no serial or parallel ports on this laptop.

Last edited 8 years ago by David McKenna (previous) (diff)

comment:6 Changed 8 years ago by dazarewicz

It has been determined that there is a problem with the new PCIBUS.SNP that was distributed with the ACPI Warpin package. You could be running into this problem.

PCIBUS.SNP is not part of the ACPI project. It was just convenient to distibute the new version this way. You can try replacing PCIBUS.SNP with the original one from your eCS install CD.

Boot the eCS install CD, click past the keyboard question and agree to the license. Select "Management console" and click next. Then from the menu at the top, click "Tools" and select "Command line (CMD)". Type the following command.

COPY Z:\PCIBUS.SNP C:\OS2\BOOT

This command assumes that Z: is the ram drive that is normally created by the install CD, and C: is your boot disk. If C: is not your boot disk, change the command accordingly.

comment:7 Changed 8 years ago by David McKenna

No change in behavior when I replace PCIBUS.SNP with the original. Both no switch and /VW hang at RESOURCE.SYS on boot, /PIC boots with repeating startup sound and no WiFi? or USB functionality.

comment:8 Changed 8 years ago by David McKenna

No change in behavior with 3.19.15.

comment:9 Changed 8 years ago by David McKenna

No change in behavior with 3.20.01

I will upload a screen capture with the debug kernel and ACPI.PSD /DBGLVL=3 /OV.

Changed 8 years ago by David McKenna

Screen at hang using debug kernel

comment:10 Changed 7 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending
  • Version changed from 3.19.14 to 3.20.01

I'm surprised 3.20.01 doesn't work. The disk read error on the screen is troublesome. Even the logging from the PSD indicates a failure to read from the disk. Is your boot volume formatted HPFS or JFS?

There are other things in your previous log that are troublesome. For example, the ACPI interrupt is non-standard. You might try checking your BIOS settings. If you can set the ACPI interrupt, set it to 9. Plug and Play OS should be NO. If you can set the ACPI compatibility level, set it to the highest level you can.

comment:11 Changed 7 years ago by David McKenna

The BIOS for this laptop has almost no settings whatsoever (PhoenixBIOS)... just some bootup screen settings, RF on/off, PXE on/off, LCD brightness and some password stuff- very basic. Disk is formatted JFS.

comment:12 Changed 7 years ago by dazarewicz

I would be curious to know if the problem disappears if you use a HPFS boot disk instead of a JFS boot disk.

comment:13 Changed 7 years ago by David McKenna

I have an old hard drive I could put in it and try that... might take a while until I can spend some time on that...stay tuned.

comment:14 Changed 7 years ago by David McKenna

I installed eCS 2.1 onto an HPFS formatted disk , then added ACPI 3.20.01 and the results are identical to using JFS: boot hangs at logo with no parameter and /VW; with /PIC it boots with repeating startup sound and no USB or WiFi? functionality.

comment:15 Changed 7 years ago by David McKenna

No change with version 3.20.02.

comment:16 Changed 7 years ago by David McKenna

No change with version 3.20.03.

comment:17 follow-up: Changed 7 years ago by David McKenna

No change with version 3.20.04.

comment:18 in reply to: ↑ 17 Changed 7 years ago by dazarewicz

Replying to David McKenna:

No change with version 3.20.04.

Yeah, thanks for checking each time. There is clearly something strange about your system. I don't know what to do about it yet, but I keep seeing your ticket and I keep thinking about it. I'll eventually think of something. In fact, some of the stuff I have been working on the past week has given me some ideas and ways to collect more information.

comment:19 Changed 7 years ago by dazarewicz

  • Milestone changed from Feedback pending to Release Version 4.0.0

Summary of results from private emails:

  • The problem is that the BIOS cannot read the disk.

Other verified information:

  • The BIOS uses a non-standard ACPI interrupt.
  • ACPI errors occur when starting ACPI

comment:20 Changed 7 years ago by David McKenna

No change with version 3.21.01.

comment:21 Changed 7 years ago by David McKenna

No change with version 3.21.02.

comment:22 Changed 7 years ago by David McKenna

No change with version 3.21.03.

comment:23 Changed 7 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending

Try the new 3.21.04 version. It actually has a chance of working on your system.

Changed 7 years ago by David McKenna

ACPICA$ from 3.21.04

comment:24 follow-up: Changed 7 years ago by David McKenna

Wow! 3.21.04 boots in APIC mode! There are a few oddities:

1) AMOUSE.SYS does not work (can't move cursor), but IBM mouse.sys does. AMouse used to work with the 3.18 version (last ACPI that worked).

2) Lars' new USB drivers do not work - they appear in the hardware manager, but no USB stick I have is recognized. The eCS 2.1 versions of USBEHCD and USBUHCD2 drivers work fine (USBUHCD does not - if I try to use it, it does not appear in the hardware manager). Lars drivers used to work with 3.18.

3) Some function keys that worked in 3.18 do not work - in particular the keys that change screen brightness. Others do work.

4) System can suspend, but not resume. There is no PS/2 keyboard port, or internal speaker so I don't know how far it gets - the only thing I can say that happens at resume is the DVD player is checked.

This is fantastic progress... thanks! There are some odd entries in ACPICA$ that may be interesting so I'll post...

Last edited 7 years ago by David McKenna (previous) (diff)

comment:25 Changed 7 years ago by dazarewicz

  • Version changed from 3.20.01 to 3.21.04

Why do you use the /EIS switch?

The file you attached is not really useful. Please install the debug version of the ACPI software, remove the /EIS switch, add the /DBGLVL=3 switch, reboot, and run "testlog acpi" and attach the zip file.

Changed 7 years ago by David McKenna

Testlog for booting 3.21.04 in APIC mode

comment:26 Changed 7 years ago by David McKenna

/EIS was left over from 3.18... I originally put it there to suppress some errors in ACPICA$. Probably didn't really need it.

I just uploaded the testlog you requested.

comment:27 in reply to: ↑ 24 Changed 7 years ago by dazarewicz

Replying to David McKenna:

Wow! 3.21.04 boots in APIC mode! There are a few oddities:

1) AMOUSE.SYS does not work (can't move cursor), but IBM mouse.sys does.

Is the mouse a PS/2 mouse?

2) Lars' new USB drivers do not work - they appear in the hardware manager, but no USB stick I have is recognized. The eCS 2.1 versions of USBEHCD and USBUHCD2 drivers work fine (USBUHCD does not - if I try to use it, it does not appear in the hardware manager).

Which version of Lars' USB drivers? My experience is that 10.185 works fairly well. Higher versions have problems.

comment:28 Changed 7 years ago by David McKenna

The mouse is a touchpad on the laptop I believe uses the PS/2 bus - hardware manager indicates PS/2 device. I tried the test amouse.sys you sent me, but it also does not work.

I tried the latest version of Lars' USB drivers (10.187). Those are the only ones currently on HOBBES and I didn't save a copy of 10.185. Do you know where I can get 10.185?

Last edited 7 years ago by David McKenna (previous) (diff)

comment:29 Changed 7 years ago by dazarewicz

Sorry I forgot this was a laptop. Just out of curiosity, if you boot with the /VW switch, does the touchpad and USB work?

comment:30 Changed 7 years ago by David McKenna

If I boot with the /VW switch the AMouse driver works, but I get the dreaded repeating desktop startup sound, the USB drivers do not get an IRQ (according to hardware manager) and the WiFi? does not work. Do you want another testlog?

comment:31 Changed 7 years ago by dazarewicz

  • Milestone changed from Feedback pending to Release Version 4.0.0

No, thanks, no new log is needed. I'll have to think on this a bit.

comment:32 Changed 7 years ago by David McKenna

For the record... I discovered that Lars' USB 1.1 drivers work fine, but not the USB 2.0 driver. This is also true with version 10.185 (thanks for sending that). Replaced Lars' EHCI driver with the eCS 2.1 supplied IBM one and now everything works.

comment:33 Changed 7 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from assigned to closed

Ok, I am closing this ticket since all the PSD issues are resolved. For now, you can use the MOUSE.SYS driver since the touchpad doesn't need any of the special features of AMOUSE.SYS. However, I am making a note to get back with you regarding the AMOUSE driver as a separate issue.

Note: See TracTickets for help on using tickets.