Opened 7 years ago

Closed 6 years ago

#520 closed defect (Unsupported Version)

With snaps it stops when i see the snap version and it should swith to desktop

Reported by: Tellie Owned by: eco
Priority: major Milestone: Release 4.00
Component: ACPI PSD Version: 3.19.11
Keywords: Cc:

Description

Hi, Have a PciE G550 matroxcard, and whith snap enabled it stops when it supose to get switch to desktop.

Joachim thinks this is a Acpi thing.

So far when i use panorama the acpi is working well.

Attachments (1)

Tellie_Comp-20111113-acpi-3.19.10.zip (24.7 KB) - added by Tellie 7 years ago.
testlog

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by Tellie

testlog

comment:1 Changed 7 years ago by jojo

Sorry, I was confused. Obviously this is a SNAP thing, it appears that no PCIe devices are supported by SNAP natively, and in this case it's even worse.

Am not sure if it is related to ACPI at all, but the logs may prove useful anyway.

Thanks for reporting though.

Joachim

comment:2 Changed 7 years ago by Tellie

Hmmm i'm confused to now, cause from the first talk we had you talked about acpi will fix this issue. But now you say it's snap..... So it seems a never ending story. I bought this card cause you say it's supported by snap. And after waiting many weeks, notting has change. So now i made my choice and say goodbye to OS/2. and that after 21 years.....

comment:3 Changed 7 years ago by eco

e-co:

Temporary solution: you can resolve the problem if invest 100-200 euro: buy other motherboard (based on other chipset) which doesn't have troubles with MTRR.

comment:4 Changed 7 years ago by Tellie

E-co You send me that money, after i spend 110 euro for that videocard ?

But this getting off topic..

This is about acpi after all..

comment:5 Changed 7 years ago by jojo

Tellie,

like I said it's a mistake from my side. It appears that SNAP does not support PCIe devices, although the chipset itself (like the Matrox G550 or the ATI X1300) *is*. It seems that this is unrelated to ACPI though. We will update SNAP sooner or later to support these PCIe devices too.

I agree that changing the motherboard won't solve much, in this case.

Apologies again,

Joachim

comment:6 Changed 7 years ago by Tellie

Joachim,

As you told me before, it takes time for a newer snap. But i'm tired to run a OS thats so slow. Have a I5. If mplayer says: Your system is too SLOW to play this!

So time is come to move on, and have no time to wait for a updated Snap.

So you can close this ticket, as it's not releated to Acpi..

comment:7 Changed 7 years ago by ecsnl

Its a complicated mess that is fixed! Acpi 3.19.11 will be rolled out this week for EDG members. This will contain a new version of ACPI from David that fixes the issue's with the embedded controller version. Now we have 1 setting for embedded and not 3...

As for your issue 3 things can cause this problem as the readme of ACPI describes!

The ibmkbd.sys contains a nasty bug. The public release version will contain an updated

version!

Second a fixed version of DOSCALL1.DLL to fix the dosstartsession bug on SMP systems.

Loading SNAP can change the timing of the WPS loading. With the new ACPI these problems can popup because this version of ACPI are much faster and efficient then older versions of ACPI! This in turn can bring the doscall1.dll bug faster to the surface.

Item 3 is that to my best understanding SNAP needs to be updated. Joachim is in touch with Steve Levine to see how we can compile SNAP to support chipsets that are supported but have a different chipset ID.

Steve has however been extremely busy with this type of Steve to figure out how to fix DOSCALL1.DLL problem!

Next to that Mensys is moving offices within Haarlem. We hope to wrap up this on the first/second of December. That also been consuming to much of my time...

Roderick Klein Mensys

comment:8 Changed 7 years ago by ecsnl

I don't know how difficult it is for Steve to update that Matrox driver... I have always had the policy with SNAP we should first add proper VESA support! Steve Levine CAN compile new SNAP builds. We have already done this. Its also in SVN. So we can make an update with the chipset ID. Because I think the Matrox 550 is supported just not your chipset ID.

What you can try and do is go into your config.sys and set the protshell to CMD.EXE. Then run GACTRL.EXE from the SNAP directory and reduce the accelration. See if that helps ?

Roderick

comment:9 Changed 7 years ago by Tellie

Roderick,

I tried the newer ibmkbd.sys also the fixed doscall and also acpi 3.19.11

For me this is not working.

But i hope for other peeps it will.

comment:10 Changed 7 years ago by Tellie

Roderick,

Just tried that what you suggest, but as soon i push gactrl i see the line "Oem version lisenced to: Serenity Systems" and then notting and i need to boot. Just like all the time i use snap...

comment:11 Changed 6 years ago by dazarewicz

  • Resolution set to Unsupported Version
  • Status changed from new to closed

It is hard to tell what is going on here. Desktop startup problems are usually not PSD related. There are a number of issues that could cause the desktop to not start, none of which are related to the PSD.

If you have desktop startup issues, it is best to use ALT-F2 or ALT-F4 to see what config.sys entry is causing the problem. Please see: http://svn.netlabs.org/acpi/wiki/TestingGuide

Additionally, version 3.19.10 and 3.19.11 were never official releases. The first official release was 3.19.14 and now we are at 3.19.15. Since this is still a beta phase of the ACPI software, please always try the latest version.

Note: See TracTickets for help on using tickets.