Opened 7 years ago

Closed 6 years ago

#519 closed defect (Unsupported Version)

Report: ACPI v3.19.10

Reported by: losepete Owned by: dazarewicz
Priority: blocker Milestone: Feedback pending
Component: ACPI PSD Version: 3.19.10
Keywords: Cc: acpi@…

Description

Sorry to report this build of acpi does not work with nVidia nForce4 chipset - to the extent that it is not possible to obtain a log.

Mainboard: Asus A8N-E using nVidia nForce4/CK804 chipset

OS: Fresh install of eCS2.1, no ACPI installed during install of eCS2.1

Using USB drivers supplied with eCS2.1

This system is in good working order, boots and runs fine without acpi installed.

I installed the acpi files and added PSD=ACPI.PSD to the config.sys file then rebooted.

Results: System fails to boot; hangs on the eCS2 splash screen.

Deleting the os2logo file (splash screen) from the boot drive root and rebooting I can report the system stops with the kernel version "Internal Revision 14.105_SMP" as the last line displayed onscreen.

Looks like acpi.psd fails instantly.

I changed the config.sys line to PSD=ACPI.PSD /VW and rebooted

Results: I can report that the system does boot but *hangs* just before the Desktop loads - the Desktop background colour is displayed, the Startup sound does not play and the mouse cursor and timer are frozen onscreen. The keyboard works so the Ctrl-Alt-Delete keys (not the application of that name installed by eCS2.1) can be used to reboot system.

I tried booting the system 5 times with the same results as above.

I installed the current IBMKBD.SYS from David and the current USB Controller drivers - but not the included usbd.sys - from Lars. I changed the config.sys line back to PSD=ACPI.PSD and rebooted.

Results: System fails to boot; hangs with kernel version displayed - as previously.

I then changed the config.sys line to PSD=ACPI.PSD /VW and rebooted.

Results: No change from the previous attempt at booting using this config.sys line - the system does boot but *hangs* just before the Desktop loads - the Desktop background colour is displayed, the Startup sound does not play and the mouse cursor and timer are frozen onscreen. The keyboard works so the Ctrl-Alt-Delete keys (not the application of that name installed by eCS2.1) can be used to reboot system.

I tried booting the system 5 times with the same results as above.

We have already established that the system boots and runs fine without acpi which is the same as testing the config.sys line REM PSD=ACPI.PSD

I changed the config.sys line to PSD=ACPI.PSD /PIC and rebooted.

Result: The system booted and seems to work OK.

I then installed the debug versions of the acpi files, changed the config.sys line to PSD=ACPI.PSD /DBGLVL=2 and rebooted.

Result: Boot stops with Kernel Revision displayed (same as PSD=ACPI.PSD)

I then changed the config.sys line to PSD=ACPI.PSD /DBGLVL=2 /VW and rebooted.

Results: Boot *hangs* just before the Desktop loads - the Desktop background colour is displayed, the Startup sound does not play and the mouse cursor and timer are frozen onscreen. The keyboard works so the Ctrl-Alt-Delete keys (not the application of that name installed by eCS2.1) can be used to reboot system.

Sorry but it seems this build of acpi does not like this nVidia chipset.

Anything else I can do to help identify the problem(s)?

Change History (6)

comment:1 Changed 7 years ago by dazarewicz

I installed the acpi files and added PSD=ACPI.PSD to the config.sys file then rebooted.

Results: System fails to boot; hangs on the eCS2 splash screen.

This appears to be a valid issue. Does this system have a serial port?

I changed the config.sys line to PSD=ACPI.PSD /VW and rebooted

Results: I can report that the system does boot but *hangs* just before the Desktop loads >- the Desktop background colour is displayed,

This is probably not a problem with the PSD. Please read the Testing Guidelines on the WIki. You are probably experiencing the DosStartSession bug. You may need to wait until the patched DOSCALL1.DLL is released.

I changed the config.sys line to PSD=ACPI.PSD /PIC and rebooted.

Result: The system booted and seems to work OK.

This pretty much confirms that you are experiencing the DosStartSession bug in DOSCALL1.DLL.

comment:2 Changed 7 years ago by losepete

No serial port installed.

I also think you could be wrong about "This pretty much confirms that you are experiencing the DosStartSession? bug in DOSCALL1.DLL."

My reason for saying this is that I have just installed and tested acpi v3.19.11

This has exactly the same problems reported above with acpi v3.19.10 *but* does have the updated doscall1.dll and tcpip32.dll files installed.

So, either the problem is not doscall1.dll related or the updated doscall1.dll does not work as it should.

comment:3 Changed 7 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending
  • Owner changed from eco to dazarewicz
  • Status changed from new to assigned

I now have a system with an ASUSTeK A8N-SLI motherboard in my test lab. Not exactly the same as yours, but similar enough that it appears to have had the same problems. This system now works well with the latest 3.20.01 release.

This particular motherboard still has a problem in /VW mode, but it works fine in normal mode with no switches.

Please try the latest version.

comment:4 Changed 7 years ago by yoda

  • Cc acpi@… added

There exists as you say several diferent versions of Asus A8N MoBo?'s. While the A8N SLI Premium always worked perfect with all of Pavels previous drivers, there were always reported very different problems for the other A8N boards with the same driver. Nvidia seems to have made several different versions of the chipset with different feature sets, and it looks like A8N boards all use different ones. From history, I guess they need to be handled differently.

comment:5 Changed 6 years ago by losepete

I have now tested with the 3.20.01 release and opened ticket 544 so I guess you can Close this ticket.

comment:6 Changed 6 years ago by dazarewicz

  • Resolution set to Unsupported Version
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.