Opened 8 years ago

Closed 8 years ago

#517 closed defect (unknown)

Report: nVidia nForce430 chipset using acpitest-20110808

Reported by: losepete Owned by: dazarewicz
Priority: blocker Milestone: Feedback pending
Component: ACPI PSD Version: 3.18
Keywords: Cc:

Description (last modified by ecsnl)

I installed the files from I then edited the config.sys line to

PSD=ACPI.PSD

and rebooted.

Boot stops after floppy disk drive seek with the last text line:-

Internal revision 14.105_SMP

and the hard disk led stays on.

I rebooted to a command line and edited config.sys acpi line to:-

PSD=ACPI.PSD /SMP /APIC

I then rebooted.

Boot fails as above.

I then booted to a command line and changed the config.sys acpi line to:-

PSD=ACPI.PSD /SMP /PIC

Rebooting was successful.

Conclusion: acpi.psd is unable to boot my system when trying to use APIC.

Anything I can do to help rectify this?

Change History (11)

comment:1 Changed 8 years ago by losepete

Something that I have only just noticed:-

Using PSD=ACPI.PSD /SMP /PIC results in only *1* cpu core in use.

Previous builds of acpi using the above config.sys line always found both cores of my cpu.

comment:2 Changed 8 years ago by mckinnis

I don't have a problem with ACPI.PSD recognizing both Intel CPUs. However, my PCI serial port card refuses to be recognized by COM.SYS. It works fine with OS2APIC.PSD.

comment:3 Changed 8 years ago by David McKenna

Chuck... did you try PSCOM.SYS?

Pete... sorry to hear you are having such a hard time with your hardware and ACPI. There is a new test version out (0821) - maybe worth a try?

comment:4 Changed 8 years ago by mckinnis

I will probably try PSCOM.SYS when I get a chance.

Did get error message on VPIC.SYS until I put it in \OS2.

Would help if the zip file came with the directories in it.

comment:5 Changed 8 years ago by ecsnl

  • Description modified (diff)

comment:6 Changed 8 years ago by ecsnl

Sorry to have jumped into here and remove the link... While some people know the link where to get these new PSD versions, testing these new PSD's builds is currently not worth the trouble (unless somebody pointed you to it that works on ACPI).

Its only worthwhile testing unless you know what the limitations are and what is all being modified. David is working on updating large portions of the PSD.

Switches like /SMP and /APIC are gone (it should selected automatically). The APIC, PCISCAN, OEMHLP and code is being worked on. The new ACPI deamon has throttle support build in (AMD not yet supported).

So unless instructed to test the PSD, please don't and don't distribute the link. As the current versions from David still need more work.

Roderick Klein Mensys

Last edited 8 years ago by ecsnl (previous) (diff)

comment:7 Changed 8 years ago by ecsnl

You might also want to consider reading the readme file that the PSD comes with. As mentioned unless you where pointed to somebody to test the PSD I have said nothing. But it seems you have not read the readme file. The /APIC and /SMP switch are gone.

So please wait for an official public release.

comment:8 Changed 8 years ago by losepete

Hi Roderick

The readme file was not present in the build tested hence the lack of knowledge regarding /APIC and /SMP switches.

Hopefully the fact that I have reported the failure to initialise both cpu cores is of some help.

Yes, quite happy to wait for a "public" test build :-)

Regards

Pete

comment:9 Changed 8 years ago by losepete

Hi Roderick

I'm sorry - curiosity overcame me - but I had to download the acpitest-20110821.zip and have a look at the readme file.

The 1st paragraph suggests to me that David wants people to test this build:-

"This version of ACPI.PSD and related files is a preview build for testing only. This is a "preview" version and still under heavy development. I will not be troubleshooting specific problems with this version. However, I would be interested to know if it boots the systems you try it on or not. Please DO NOT report other problems with this PSD or related files to me unless specifically requested below."

Well, I've been a bad boy and installed these files - and they seem to work fine.

I've emailed David with my feedback.

Hopefully you will not be too cross about this :-)

Regards

Pete

comment:10 Changed 8 years ago by dazarewicz

  • Milestone changed from Release version 3.19 to Feedback pending
  • Owner changed from eco to dazarewicz
  • Status changed from new to assigned

Have you tried the new 3.20.01 release?

comment:11 Changed 8 years ago by dazarewicz

  • Resolution set to unknown
  • Status changed from assigned to closed

No response from reporter.

Note: See TracTickets for help on using tickets.