Opened 7 years ago

Closed 6 years ago

#516 closed defect (wontfix)

http://local.88watts.net/software.html gives 'Error 404'

Reported by: David McKenna Owned by: eco
Priority: major Milestone: Release version 3.19
Component: ACPI PSD Version: 3.19.02
Keywords: Cc:

Description

The link 'http://local.88watts.net/software.html' shown in the Wiki for the 3.19.02 version of ACPI gives an 'Error 404'.

Change History (10)

comment:1 Changed 7 years ago by losepete

Looks like no-one is interested in resolving the bad url error.

Does not give me much hope that acpi will ever work properly...

comment:2 Changed 7 years ago by David McKenna

Have a look at:

I tried the 0808 test version and it seems to work well so far. A couple of observations:

  1. It doesn't work with the OS4 loader (hangs at logo).
  2. The VPIC.SYS included traps my eCS 2.1 system when I open a WinOS/2 session (eCS supplied one does work).

Otherwise booting seems slightly faster, especially the time the logo appears is shorter. One other thing - even though I am using an Intel based system (H55 chipset, i3 processor) power management does not work (didn't with the eCS supplied ACPI either).

Last edited 7 years ago by ecsnl (previous) (diff)

comment:3 Changed 7 years ago by David McKenna

Another thing I just noticed... if I just have PSD=ACPI.PSD (no switches) in CONFIG.SYS it figures out that it is SMP and APIC automatically.... nice!

comment:4 Changed 7 years ago by mckinnis

I have noticed the same behavior as David. This is the first ACPI.PSD that has worked in some time on my Lenovo M55. Have not tried APM.

comment:5 Changed 7 years ago by losepete

Thanks for the correct url

I've now installed this build and, sadly, do not find it working as reported above - I have to use PSD=ACPI.PSD /SMP /PIC otherwise the system fails to boot; does not even get as far as displaying any acpi messages.

comment:6 Changed 7 years ago by losepete

Huh.

Just noticed that using PSD=ACPI.PSD /SMP /PIC results in only 1 active cpu core - cpu is an AMD64x2 4400.

This is *worde* than previous acpi builds which always found and initialised both cores.

comment:7 Changed 7 years ago by ecsnl

In ticket 517 I posted these 2 comments:

Sorry to have jumped into here and remove the link... While some people know the link where to get these new PSD versions, testing these new PSD's builds is currently not worth the trouble (unless somebody pointed you to it that works on ACPI).

Its only worthwhile testing unless you know what the limitations are and what is all being modified. David is working on updating large portions of the PSD.

Switches like /SMP and /APIC are gone (it should selected automatically). The APIC, PCISCAN, OEMHLP and code is being worked on. The new ACPI deamon has throttle support build in (AMD not yet supported).

So unless instructed to test the PSD, please don't and don't distribute the link. As the current versions from David still need more work.

Roderick Klein Mensys Last edited 2 hours ago by ecsnl (previous) (diff) comment:7 Changed 4 minutes ago by ecsnl

You might also want to consider reading the readme file that the PSD comes with. As mentioned unless you where pointed to somebody to test the PSD I have said nothing. But it seems you have not read the readme file. The /APIC and /SMP switch are gone.

So please wait for an official public release.

Roderick

comment:8 Changed 7 years ago by David McKenna

Roderick,

The 0808 test version did not have a 'readme'. I see in the 0821 version it does and mentions switches are not needed. It also says that David is interested in knowing if people can boot with this version (or not).

I certainly will not distribute something clearly marked a test version as you wish. But I have to wonder why a link is given on the Wiki page saying there is a new version available but here you say you don't want anyone trying it (without explicit instructions to do so)...

In any case, David's new versions seem promising on my hardware. Thanks for continuing this project!

comment:9 Changed 7 years ago by David McKenna

Another discovery: If I add /MAXCPU=4 to ACPI.PSD in CONFIG.SYS, PowerMan? works. woohoo!

comment:10 Changed 6 years ago by dazarewicz

  • Resolution set to wontfix
  • Status changed from new to closed

There was never intended to be a link on the wiki page.

Note: See TracTickets for help on using tickets.