Opened 9 years ago

Closed 7 years ago

#498 closed defect (fixed)

Asus M4A87TD + acpi v3.19CR4 = AcpiOsSignalSemaphore BAD

Reported by: kmarjerison Owned by: dazarewicz
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.19
Keywords: Cc:

Description

Both 3.18 and 3.19 partially work(SMP but no APIC), but not with uniaud driver. acpica$ is mostly full of AcpiOsSignalSemaphore? BAD statements and not much else.

Attachments (4)

acpica.log (37.1 KB) - added by kmarjerison 9 years ago.
acpica log
acpicaPolling.log (24.8 KB) - added by kmarjerison 9 years ago.
config.sys (7.9 KB) - added by kmarjerison 9 years ago.
uniaud.log (17.8 KB) - added by kmarjerison 9 years ago.

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by kmarjerison

acpica log

comment:1 Changed 9 years ago by pasha

  • Owner changed from eco to pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

acpi319PollingFullOnly.zip

comment:2 Changed 9 years ago by kmarjerison

Hello Pasha; I get the same results from "acpi319FullOnly.zip" as I did with v3.18 and v3.19CR4, my system will not boot with any form of "acpi.psd" and uniaud drivers in config.sys. As with previous versions, without uniaud drivers system will boot with /SMP /CD /R switches but not /APIC switch, and all cores are recognized. The system seems stable, but as I say no sound. Without the "acpi.psd" in my config.sys, it takes between 30 and 35 sec. to boot to a working desktop from the time you select an OS. With any form of "acpi.psd" and uniaud drivers in config.sys, it loads fast until it gets to the uniaud drivers and then it slows right down and after between 10 and 15 min. it hangs with Unmask IRQ 0 mask:FFFFD878 as the last output to the screen. I am unable to send another acpica.log because copy acpica$ >acpica.log does not work. With the /SMP switch one core pegs out at 99.9% and eventually(I gave up after 5 min.) you have to close the command prompt window because nothing is happening, and the same happens without the /SMP switch. This package has an "acpiexec.exe" and an "lasl.exe" included, but there is no mention of them in the "psd_en.inf" so I am not even sure if I installed this package correctly. More documentation is needed, with a step by step approach on how to install and what to do if it doesn't work. I have no idea what I am doing, and the existing docs do not help. Any other ideas I can try?

comment:3 Changed 9 years ago by kmarjerison

Hello Pasha; I have just finished upgrading Uniaud to the beta v2.1.2 found in the "Uniaud195-212.zip" package, and now with the "acpipollingfullonly.zip" package, I can get my system to boot with acpi.psd and the /SMP /CD /R switches and sound. /APIC switch still not working, but I am now able to send "acpicaPolling.log". Note: Without "acpi.psd" in config.sys, system will boot to a working Desktop in 35 sec. with any form of "acpi.psd" in config.sys, it takes 16 sec to get to the Uniaud drivers and then over 5 min. to get to a working Desktop. Now with current Uniaud and Acpi drivers system is stable, but as I say, very slow to start.

Changed 9 years ago by kmarjerison

comment:4 Changed 9 years ago by pasha

can you attach your config.sys?

Changed 9 years ago by kmarjerison

comment:5 Changed 9 years ago by pasha

can you do "copy alsahlp$ uniaud.log" and attach this log here

Changed 9 years ago by kmarjerison

comment:6 Changed 8 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

acpi319for105-2011-05-30.zip

comment:7 Changed 8 years ago by pasha

  • Owner changed from pasha to dazarewicz

comment:8 Changed 8 years ago by dazarewicz

  • Milestone changed from Release version 3.19 to Feedback pending

This ticket appears completely unrelated to the current software. What is the status of this using the current software?

comment:9 Changed 7 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from new to closed

No response from reporter. This ticket is no longer applicable to the current revision of the software.

Note: See TracTickets for help on using tickets.