Opened 10 years ago

Closed 7 years ago

#420 closed defect (fixed)

316FULL not very compatible with nForce430/MCP61 chipset

Reported by: losepete Owned by: eco
Priority: major Milestone: Release 4.00
Component: ACPI PSD Version: 3.14
Keywords: Cc:

Description

As usual the update contains files that do not currently exist on this system and the update contains no useful information about these files or where to locate them.

I put acpiexec.exe into \os2 and the table.* files into \os2\boot - maybe those locations are OK?

Installed updates, changed config.sys line to PSD=ACPI.PSD /SMP /ACPI and rebooted.

Boot failed at the (usual) USBEHCD.SYS driver.

Edited config.sys and removed all USB drivers then tried rebooting.

Boot failed when loading uniaud drivers.

Edited config.sys and removed uniaud drivers then tried rebooting.

Booted successfully to a working Desktop. I immediately used the CollectLogs?.cmd to generate 316Full_acpi-log-Model-of-your-PC.ziq which is attached to this report.

Brief testing shows that the /TMR switch is required but as a Sound-less and USB-less system is of no use to me I reinstated uniaud and usb drivers in the config.sys file. I also changed the PSD= line to PSD=ACPI.PSD /SMP /CD /TMR /ACPI /!NOD and rebooted successfully to a working system with Sound and USB capability.

It is possible that like previous builds of acpi 3.16 the system will not be able to boot after being powered off for a few hours.

Results of Powering Off system and restarting at least 30 minutes later:

When the system is Powered Off and left for a minimum of 30 minutes *every* first attempt at booting stops just as the Desktop is about to load. Sometimes the Startup sound gets played, sometimes it does not, sometimes the sound plays and gets stuck in a "repeat loop" playing just the very end of the sound continuously. Using Ctrl-Alt-Del to restart the system there is no problem getting to a working Desktop. Seems the system now needs 2 attempts before booting is successful - maybe there is a problem with acpi and uniaud that does not exist when using acpi v3.14.

My 1st attempt to actually use an application resulted in a system hang: I had Seamonkey running for about 5 minutes and was scrolling a webpage when the hang occurred.

Conclusion: 316Full is not an improvement over 3.14 - in fact it is less capable on this system.

I have reverted to v3.14 as it is the last version that comes close to working.

Attachments (1)

316Full_acpi-log-Model-of-your-PC.ziq (209.1 KB) - added by losepete 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by losepete

comment:1 in reply to: ↑ description Changed 10 years ago by ggamba

Replying to losepete:

You can try acpi-20090624.zip. I had your same problems with ACPI316FULL.ZIP, while latest release of 3.16 works again well as 3.14 (well... with /!NOD :-\

Bye

Gabriele

comment:2 Changed 10 years ago by losepete

Hi Gabriele

Nice thought.

The result is http://svn.netlabs.org/acpi/ticket/432

Regards

Pete

comment:3 Changed 10 years ago by David McKenna

Pete,

I had a quick look at your log file and I notice these two lines:

0:28:28 0:8.1 10DE:3F6 'ATA1' IRQs: PCI:0 PIC:'LSA1':0 APIC:'LSA1':22 Set: 22 MSI

0:28:28 2:0.0 1002:554E IRQs: PCI:0 PIC:'LNED':0 APIC:'LNED':16 Set: 16 MSI

Notice they both have 'PCI:0' in them. This is bad... you could try adding:

LINK LSA1 5

LINK LNED 7 (or 10, 11 ,14)

to your ACPI.CFG file and see if there is any improvement. Try this with ACPI.PSD /SMP /APIC /TMR at first.

I had similar issues with both my laptop and desktop machines. Doing this fixed the laptop issues, but did not help the desktop (although it didn't hurt either).

Dave McKenna?

comment:4 Changed 7 years ago by dazarewicz

  • Milestone changed from Release version 3.19 to Feedback pending

This ticket is for an unsupported version. Have you tried the new 3.20.01 release?

comment:5 Changed 7 years ago by ggamba

Hi David,

my system (Nvidia based) works fine with 3.20.01.

Last edited 7 years ago by ggamba (previous) (diff)

comment:6 Changed 7 years ago by dazarewicz

  • Milestone changed from Feedback pending to Release Version 4.0.0
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.