Opened 10 years ago

Closed 8 years ago

#419 closed defect (unknown)

ACPI 3.xx not working in SMP mode.

Reported by: rdod Owned by: eco
Priority: major Milestone: Release version 3.19
Component: ACPI PSD Version: 3.14
Keywords: Cc:

Description

Hi! I had a working eCS V2b3 and i installed the new eCs v2.0RC6 on the same system but new partition on a new SSD disk. I was able to install and start in simble CPU mode but as soon I enables /SMP and with all possible switches, it always failed with trap008 or trap00d or hung ! And during the traps, I've lost the partition or partition was made unreadable resulting into new installation at each test which made me angry due the SSD disk has short life time (near 10000 write only per address) . The only solution for me was to go back with the ACPI version to the latest 2.22 wich works in SMP mode. Config: ASUS A8N-SLI Prenmium Video ATI X850 card (had to use special AT db files I received from SNAP support in the past due the ones from the 3.18 supposed to support X850 didn't work) SNAP 3.1.8 installed. ACPI tested Version: 3.14, 3.15 and 3.16 working version: 2.22 !

Change History (11)

comment:1 Changed 10 years ago by pasha

Check \os2\boot\snoop.lst for absent acpisnp.snp

comment:2 Changed 10 years ago by rdod

Yes acpisnp.snp is missing from snoop.lst and each changes made through the wizard tool removes it. BUT, despite adding an entry ACPISNP.SNP into snoop.lst file, it didn't help and I always have trap or hung with any tested flags. The latest test I did was under silver version and I'm unable to make it working in SMP mode ! Bye/2 * only V2.2x is ok in SMP mode *

comment:3 Changed 10 years ago by eco

e-co:

Remy needs help:

PC: ASUS A8N-SLI Premium

chipset: NVidia chipset (?)

Message 1:

tried to enable ACPI and I always gor a hung on boot logo. I tried /SMP /ACPI I tried /SMP /ACPI /TMR I would like try /SMP /ACPI /!NOD but the required acpica.add driver is missing from installation ! Up to now, all test to activate /SMP support failed !

http://ecomstation.ru/temp/200908/remy-01.zip

Message 2:

I tried to start SMP mode but it always failed with trap00D or hung at WPS start ! I tried every possible combination using one or more of following flags /SMP /ACPI /R /CD /!NOD /TME /B Finaly, I replace the 3.xx ACPI with he older 2.xx and SMP mode boot up ok. According a open thread for the same problem opened during RC6a test, this ACPI v3.xx never works and none could explain me why ! I checked all required files and all are ok. The problem is the same using panorama or snap video driver.

Message 3:

More logs: http://ecomstation.ru/temp/200908/remy-02.zip

comment:4 follow-up: Changed 10 years ago by pasha

Say me pls, where in our .inf /ACPI options is present?

comment:5 in reply to: ↑ 4 Changed 10 years ago by rdod

Replying to pasha:

Say me pls, where in our .inf /ACPI options is present?

It is a typo error, read APCI (the wizard tool is setting it too)

comment:6 Changed 10 years ago by rdod

Why this typo in the comments I provided but not on the tests I did ? (ACPI wizard but APCI flag)

comment:7 Changed 10 years ago by rdod


Hardware overview generated by ACPIWZRD.EXE at 20090803 - 01:03:40


[CPU info - 1 CPU(s) found] manufacturer: AMD socket: Socket 939 family: Athlon 64 type: AMD Athlon(tm) 64 X2 Dual Core Processor 4400+ signature: Family 15, Model 35, Stepping 2 ID: 32 0F 02 00 FF FB 8B 17 SMP capable: yes

[BIOS info] manufacturer: Phoenix Technologies, LTD version: ASUS A8N-SLI Premium ACPI BIOS Revision 1303 date: 08/10/2006

[Systemboard info] manufacturer: ASUSTeK Computer INC. type: A8N-SLI Premium version: 1.02

[System info] serial: 123456789000 vendor: System manufacturer product: System Product Name version: System Version serial: System Serial Number uuid: 11111111-1111-1111-1111-111111111111 suid: EN12UMG5K56K4R9K6-11000B9A-1 type: Desktop

[Kernel info] level: IBM:14.104a description: SMP

[ACPI installed] level: 3.16 config.sys: PSD=ACPI.PSD

[Detected (PCI) devices] nVidia Corporation - CK804 Memory Controller nVidia Corporation - CK804 ISA Bridge nVidia Corporation - CK804 SMBus nVidia Corporation - CK804 USB Controller nVidia Corporation - CK804 USB Controller nVidia Corporation - CK804 AC'97 Audio Controller nVidia Corporation - CK804 IDE nVidia Corporation - CK804 Serial ATA Controller nVidia Corporation - CK804 Serial ATA Controller nVidia Corporation - CK804 PCI Bridge nVidia Corporation - CK804 Ethernet Controller nVidia Corporation - CK804 PCIE Bridge nVidia Corporation - CK804 PCIE Bridge nVidia Corporation - CK804 PCIE Bridge nVidia Corporation - CK804 PCIE Bridge Advanced Micro Devices [AMD] - K8 [Athlon64/Opteron] HyperTransport? Technology Configuration Advanced Micro Devices [AMD] - K8 [Athlon64/Opteron] Address Map Advanced Micro Devices [AMD] - K8 [Athlon64/Opteron] DRAM Controller Advanced Micro Devices [AMD] - K8 [Athlon64/Opteron] Miscellaneous Control ATI Technologies Inc - R480 [Radeon X800 GTO (PCIE)] ATI Technologies Inc - R480 [Radeon X800 GTO (PCIE)] (Secondary) Agere Systems - Venus Modem (V90, 56KFlex)

[Detailed CPU information] vendor_id = "AuthenticAMD" version information (1/eax): processor type = primary processor (0) family = Intel Pentium 4/Pentium D/Pentium Extreme Edition/Celeron/Xeon/Xeon? MP/Itanium2, AMD Athlon 64/Athlon XP-M/Opteron/Sempron/Turion (15) model = 0x3 (3) stepping id = 0x2 (2) extended family = 0x0 (0) extended model = 0x2 (2) (simple synth) = AMD Dual Core Opteron (Denmark JH-E6) / Athlon 64 X2 (Toledo JH-E6), 939-pin, 90nm miscellaneous (1/ebx): process local APIC physical ID = 0x0 (0) cpu count = 0x2 (2) CLFLUSH line size = 0x8 (8) brand index = 0x0 (0) brand id = 0x00 (0): unknown


comment:8 Changed 10 years ago by rdod

Hi! I redo a test like I previously did using wizard tool. I added parm /!NOD with the proposed wizard parms which should be ok ( /SMP /APCI ) * After reboot, it hung but I saw that it didn't add the SMP flag after amouse driver. I added it and reboot. This time, it start !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! I'll redo a full install and test this again because this troubles me. am I tired as much to not remember what I do ? strange. I let you know as soon as I could do a new install on an empty partition.

comment:9 Changed 10 years ago by rdod

Hi! I would like add the changes I did before this new test. I changed the installed panorama with the SNAP driver (but it wasn't nice due to ATOMBISO I left under config.sys and id didn't change rendering nor visible performence

I used wizard to switch to panorama again (this was ok) But I saw that a SNAP folder was left on the desktop. I run than uninstall which removecd drivers (all drivers !) and At reboot time, I was in VGA mode. I installed panoprama again + reboot which was finally ok. Only after all these changes, I redo the previous test with good results now ! Bye/2 Remy

comment:10 Changed 10 years ago by rdod

Hi! I would like add the changes I did before this new test. I changed the installed panorama with the SNAP driver (but it wasn't nice due to ATOMBIOS I left under config.sys and it didn't change rendering nor visible performence. I use now panorama instead of SNAP.

comment:11 Changed 8 years ago by dazarewicz

  • Resolution set to unknown
  • Status changed from new to closed

This ticket is for an unsupported version. Please open a new ticket if you still have problems after using the current version.

Note: See TracTickets for help on using tickets.