Opened 9 years ago

Closed 6 years ago

#396 closed defect (fixed)

Asus M2A-MX ACPI problem

Reported by: RodneyPont Owned by: eco
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.15
Keywords: Cc:

Description

I've tried the 3.15 prerelease on my Asus M2A-MX motherboard with an AMD Phenom X4 9780 cpu. It boots with all 4 processors running with the /SMP flag but hangs hard within an hour and needs a reset, logs attached.

With /APIC /SMP it hangs during boot, screen pic attached.

I have ticket #178 outstanding on my Asus M2A-VM HDMI motherboard and hope to be able to try 3.15PRE on that next week.

Attachments (7)

acpi-log-Asus-M2A-MX.ziq (87.3 KB) - added by RodneyPont 9 years ago.
ACPI logs
090410-Screen.jpg (82.3 KB) - added by RodneyPont 9 years ago.
Picture of screen after boot hang with /ACPI /SMP
CONFIG.SYS (18.2 KB) - added by RodneyPont 9 years ago.
acpi-log-Asus-M2A-MX-090424.ziq (87.4 KB) - added by RodneyPont 9 years ago.
acpi-log-Asus-M2A-MX-090515.ziq (139.8 KB) - added by RodneyPont 9 years ago.
acpi-test.ziq (2.1 KB) - added by RodneyPont 9 years ago.
Test results
acpi-log-Asus-M2A-MX-090515-2.ziq (87.7 KB) - added by RodneyPont 9 years ago.

Download all attachments as: .zip

Change History (32)

Changed 9 years ago by RodneyPont

ACPI logs

Changed 9 years ago by RodneyPont

Picture of screen after boot hang with /ACPI /SMP

comment:1 follow-up: Changed 9 years ago by pasha

  • Owner changed from eco to pasha

try boot with psd=acpi.psd /SMP /APIC /CD

About hang after hour. Do you use SNAP? And in any case, for SMP kernel is ready Panorama only.

comment:2 Changed 9 years ago by ecsnl

Do you mean that SNAP does not work with SMP kernel ? Or there is a specific bug on this machine that makes SMP fail with SNAP ?

comment:3 Changed 9 years ago by pasha

C:\SNAP\problems.txt:

. Running OS/2 with an SMP kernel is not supported. It may work for you,

but there are several reports of odd slowness and/or strange crashes. If you experience these kinds of problems, please report the problems to IBM, and be sure to open a PMR for it.

comment:4 Changed 9 years ago by ecsnl

What is the date of on problem.txt ? We can't find that comment in problem.txt that ships with SNAP build 505. What version of SNAP did you find it with ?

It might fail with SMP but is there an indicator in this event that SNAP is the cause ?

Question for the customer ? Can you hit CTRL ALT F10 twice to start a memory dump. Its to at least find out if the kernel is still alive in some state ? You don't have to make the dump but then we know how far the system is no longer alive.

comment:5 Changed 9 years ago by eco

e-co:

Scitech answered some weeks ago:

http://trac.ecomstation.ru/Panorama/ticket/20

comment:6 Changed 9 years ago by pasha

SciTech? SNAP Graphics for eCS Version 3.1.7, build 504 eComstation Special Edition

505 has only number+1 and absent this string in problems.txt, because IBM break support at this time.

comment:7 Changed 9 years ago by pasha

Btw, now I give support for execute at all CPU, Panorama use it for set MTRR, but Scitech is down now.

comment:8 Changed 9 years ago by RodneyPont

Tried again with SNAP and keys for memory dump had no effect, completely dead. Installed Panorama and repeated. Still hung and again no action from memory dump keys. Only a hard reset gets it going again.

comment:9 in reply to: ↑ 1 Changed 9 years ago by RodneyPont

Replying to pasha:

try boot with psd=acpi.psd /SMP /APIC /CD

Same hang on boot but missing second UMASK line. Goes straight from the line beginning SetVirtualWireMode? to the PIC MASK IRQ16 line.

About hang after hour. Do you use SNAP? And in any case, for SMP kernel is ready Panorama only.

Up to an hour. It's random but usually within 5 minutes.

comment:10 Changed 9 years ago by pasha

can you attach your config.sys? I see very strange IRQ open/close in acpi.log

Changed 9 years ago by RodneyPont

comment:11 follow-up: Changed 9 years ago by pasha

can you try boot without os2aspi.dmd ?

Changed 9 years ago by RodneyPont

comment:12 in reply to: ↑ 11 Changed 9 years ago by RodneyPont

Replying to pasha:

can you try boot without os2aspi.dmd ?

Have done so. The system ran for over 2 hours but hung when I tried to connect to this site with PmW-Firefox2_0_0_21 and I had to press reset. Maybe something doesn't like Genmac but there had been a low level of background network activity for that two hours. There was also no sound from Uniaud. I have attached the logs from a run of the log collector.

comment:13 Changed 9 years ago by pasha

Try acpi315.zip pls

comment:14 Changed 9 years ago by RodneyPont

Sorry it's taken so long but I have now tried ACPI315. It boots with /SMP only but hangs, so far only when browsing. It hung while trying to fill in this entry so I switched back to OS2APIC. It won't boot with /SMP /APIC /CD even with USB and sound disabled both in the BIOS and in config.sys. I have included a pic of the screen at this point in the attached log file of it booting with just /SMP.

Changed 9 years ago by RodneyPont

comment:15 Changed 9 years ago by eco

e-co:

Your chipset: AMD 690V (RS690 + SB600)

You havel old eComStation.. Do you see problems with the script? http://ecomstation.ru/projects/acpitools/download/acpi-test.cmd

What happens if you don't start acpi daemon?

Changed 9 years ago by RodneyPont

Test results

comment:16 Changed 9 years ago by RodneyPont

The only one that might be a problem is that I'm running the OS4 kernel since it allows me to use my floppy disk drive. With the 14.104a_SMP it hangs. I also thought the OS4 kernel was better for ACPI.

comment:17 Changed 9 years ago by eco

e-co:

1) Mensys and eCo Software don't have relation to stolen source code and pirate's site.

Let's test legal software only, i talk about IBM kernel: SMP 14.104.

2) ok.. simplify the configuration.. disable audio, floppy.. else it's difficult understand what is the problem.

3) one more suggestion for AMD chipset, try boot:

  • /SMP /!NOD /SAP:0x10

SAP:0x10 cause "don't turn on acpi HW"

comment:18 Changed 9 years ago by eco

/SMP /!NOD /SAP:0x10

where

SAP:0x10 cause "don't turn on acpi HW"

Changed 9 years ago by RodneyPont

comment:19 Changed 9 years ago by RodneyPont

Well it hasn't hung so far and this is the furthest I've gotten :-)

Logs attached in acpi-log-Asus-M2A-MX-090515-2.ziq

comment:20 Changed 9 years ago by eco

e-co:

Please continue testing PSD=ACPI.PSD /SMP /!NOD /SAP:0x10

what are the restrictions, does network hang, does USB work or not, etc.

comment:21 Changed 9 years ago by RodneyPont

I've enabled sound with Uniaud and no hangs so far. The USB printer is working as is networking although I do get a line of artifacts at the top of the screen while ftping files. Dragging a window across the line clears it but it returns when ftp is running again. It doesn't seem to be creating any problems though. Does a PCIe video card need allowing to allocate an interrupt in the BIOS?

It does seem to hijack the power button though. Usually after shutdown I can press the button to power off but it doesn't do that any more. If I hold the button in for four seconds it shuts the drives and fans off but not the power supply (going into hibernate maybe).

comment:22 Changed 8 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

acpi319ForDesktop.zip

comment:23 Changed 8 years ago by pasha

  • Owner changed from pasha to eco

comment:24 Changed 6 years ago by dazarewicz

  • Milestone changed from Release version 3.19 to Feedback pending

This ticket is very old and for an unsupported version. Have you tried the current version?

comment:25 Changed 6 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from new to closed

No response from reporter. Assumed fixed in current version.

Note: See TracTickets for help on using tickets.